summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-extended/corosync
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-extended/corosync')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync/corosync.conf85
-rw-r--r--external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_3.0.3.bb (renamed from external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb)24
2 files changed, 53 insertions, 56 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync/corosync.conf b/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync/corosync.conf
index 6aef9de9..744a30ff 100644
--- a/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync/corosync.conf
+++ b/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync/corosync.conf
@@ -1,58 +1,61 @@
-# Starting point for cluster with pacemaker/openais
-compatibility: none
-
-corosync {
- user: root
- group: root
-}
-
-aisexec {
- with Pacemaker
- user: root
- group: root
-}
-
-service {
- name: pacemaker
- ver: 1
-}
-
+# Please read the corosync.conf.5 manual page
totem {
version: 2
- secauth: off
- threads: 0
- interface {
- ringnumber: 0
- # Cluster network address
- bindnetaddr: 192.168.10.0
- # Should be fine in most cases, don't forget to allow
- # packets for this address/port in netfilter if there
- # is restrictive policy set for cluster network
- mcastaddr: 226.94.1.1
- mcastport: 5405
- }
+
+ # Set name of the cluster
+ cluster_name: testCluster
+
+ # crypto_cipher and crypto_hash: Used for mutual node authentication.
+ # If you choose to enable this, then do remember to create a shared
+ # secret with "corosync-keygen".
+ # enabling crypto_cipher, requires also enabling of crypto_hash.
+ # crypto works only with knet transport
+ crypto_cipher: none
+ crypto_hash: none
}
logging {
+ # Log the source file and line where messages are being
+ # generated. When in doubt, leave off. Potentially useful for
+ # debugging.
fileline: off
- to_stderr: no
+ # Log to standard error. When in doubt, set to yes. Useful when
+ # running in the foreground (when invoking "corosync -f")
+ to_stderr: yes
+ # Log to a log file. When set to "no", the "logfile" option
+ # must not be set.
to_logfile: yes
- to_syslog: yes
logfile: /var/log/cluster/corosync.log
+ # Log to the system log daemon. When in doubt, set to yes.
+ to_syslog: yes
+ # Log debug messages (very verbose). When in doubt, leave off.
debug: off
- timestamp: on
+ # Log messages with time stamps. When in doubt, set to hires (or on)
+ #timestamp: hires
logger_subsys {
- subsys: AMF
+ subsys: QUORUM
debug: off
}
}
-amf {
- mode: disabled
-}
-
quorum {
- # Quorum for the Pacemaker Cluster Resource Manager
+ # Enable and configure quorum subsystem (default: off)
+ # see also corosync.conf.5 and votequorum.5
provider: corosync_votequorum
- expected_votes: 1
+}
+
+nodelist {
+ # Change/uncomment/add node sections to match cluster configuration
+
+ node {
+ # Hostname of the node
+ name: node1
+ # Cluster membership node identifier
+ nodeid: 1
+ # Address of first link
+ ring0_addr: 127.0.0.1
+ # When knet transport is used it's possible to define up to 8 links
+ #ring1_addr: 192.168.1.1
+ }
+ # ...
}
diff --git a/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb b/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_3.0.3.bb
index 23a3d147..c0531d38 100644
--- a/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb
+++ b/external/meta-openembedded/meta-networking/recipes-extended/corosync/corosync_3.0.3.bb
@@ -7,19 +7,16 @@ SECTION = "base"
inherit autotools pkgconfig systemd useradd
-SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
+SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
file://corosync.conf \
"
-
-SRC_URI[md5sum] = "69db29ff4bc035936946be44fc8be5cd"
-SRC_URI[sha256sum] = "9bd4707bb271df16f8d543ec782eb4c35ec0330b7be696b797da4bd8f058a25d"
-
+SRC_URI[sha256sum] = "20eb903eb984f6a728282c199825e442e8bba869acefd22390076ef3a33a4ded"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.(?!99)\d+(\.\d+)+)"
-LICENSE = "BSD"
+LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
-DEPENDS = "groff-native nss libqb"
+DEPENDS = "groff-native nss libqb kronosnet"
SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \
${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \
@@ -30,23 +27,20 @@ SYSTEMD_AUTO_ENABLE = "disable"
INITSCRIPT_NAME = "corosync-daemon"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
- dbus qdevice qnetd snmp \
+ dbus snmp \
"
PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
-PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
-PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
-PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma"
PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash ap_cv_cc_pie=no"
EXTRA_OEMAKE = "tmpfilesdir_DATA="
-do_configure_prepend() {
- ( cd ${S}
- ${S}/autogen.sh )
-}
+#do_configure_prepend() {
+# ( cd ${S}
+# ${S}/autogen.sh )
+#}
do_install_append() {
install -D -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example