summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-support/drbd
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-support/drbd')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch43
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-utils-support-usrmerge.patch108
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb (renamed from external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb)25
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb (renamed from external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb)9
4 files changed, 123 insertions, 62 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
deleted file mode 100644
index c0f3adf2..00000000
--- a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Subject: drbd-tools: only rmmod if DRBD is a module
-
-Account for the case if the DRBD drive is built into
-the kernel. Otherwise, errors, like the following,
-will occur:
-
-root@localhost:~# /etc/init.d/drbd stop
- Stopping all DRBD resources: ERROR: Module drbd
- does not exist in /proc/modules
-
-Upstream-Status: Submitted [https://github.com/LINBIT/drbd-utils/pull/2]
-
-Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
-Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
-
-[ refresh to 8.4.4: squash Aws' and Jason's patches ]
-Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com>
-
-Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
-
----
- scripts/drbd | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/scripts/drbd b/scripts/drbd
-index 20bf628..de589dc 100755
---- a/scripts/drbd
-+++ b/scripts/drbd
-@@ -241,7 +241,9 @@ case "$1" in
- if [ -d /sys/module/drbd/holders ]; then
- (cd /sys/module/drbd/holders; for tr in *; do [ -d ${tr} ] && ${RMMOD} ${tr}; done)
- fi
-- $RMMOD drbd && break
-+ if [ ! -z "$(cat /proc/modules | grep -w drbd)" ]; then
-+ $RMMOD drbd && break
-+ fi
- fi
- done
- run_hook stop
---
-1.9.1
-
diff --git a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-utils-support-usrmerge.patch b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-utils-support-usrmerge.patch
new file mode 100644
index 00000000..5e128727
--- /dev/null
+++ b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-utils-support-usrmerge.patch
@@ -0,0 +1,108 @@
+From 642b5823abeee27a0fdc2d12d0e1235461ace9ed Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Thu, 5 Sep 2019 18:57:39 +0800
+Subject: [PATCH] drbd-utils: support usrmerge
+
+Upstream-Status: Inappropriate[oe-specific]
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ configure.ac | 2 +-
+ scripts/Makefile.in | 4 ++--
+ user/v83/Makefile.in | 14 +++++++-------
+ user/v84/Makefile.in | 14 +++++++-------
+ 4 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4df1b4d..c4ef1bc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -176,7 +176,7 @@ AC_ARG_WITH(tmpfilesdir,
+ AC_SUBST(tmpfilesdir)
+
+ # set default early
+-default_udevdir=/lib/udev
++default_udevdir=${prefix}/lib/udev
+ if test x"$with_udev" = x || \
+ test x"$with_udev" = xyes ; then
+ if test x"$PKG_CONFIG" != x; then
+diff --git a/scripts/Makefile.in b/scripts/Makefile.in
+index fbb0beb..da701a1 100644
+--- a/scripts/Makefile.in
++++ b/scripts/Makefile.in
+@@ -75,8 +75,8 @@ endif
+ ifeq ($(subst both,systemd,$(initscripttype)),systemd)
+ install -d $(DESTDIR)$(systemdunitdir)
+ install -m 644 drbd.service $(DESTDIR)$(systemdunitdir)/
+- install -d $(DESTDIR)/lib/drbd/
+- install -m 755 drbd $(DESTDIR)/lib/drbd/
++ install -d $(DESTDIR)/${nonarch_libdir}/drbd
++ install -m 755 drbd $(DESTDIR)/${nonarch_libdir}/drbd
+ install -d $(DESTDIR)$(tmpfilesdir)/
+ install -m 444 drbd.tmpfiles.conf $(DESTDIR)$(tmpfilesdir)/drbd.conf
+ endif
+diff --git a/user/v83/Makefile.in b/user/v83/Makefile.in
+index 27516de..b301376 100644
+--- a/user/v83/Makefile.in
++++ b/user/v83/Makefile.in
+@@ -96,19 +96,19 @@ install:
+ ifeq ($(WITH_83_SUPPORT),yes)
+ install -d $(DESTDIR)$(localstatedir)/lib/drbd
+ install -d $(DESTDIR)$(localstatedir)/lock
+- install -d $(DESTDIR)/lib/drbd/
++ install -d $(DESTDIR)/${nonarch_libdir}/drbd/
+ if getent group haclient > /dev/null 2> /dev/null ; then \
+- install -g haclient -m 4750 drbdsetup-83 $(DESTDIR)/lib/drbd/ ; \
+- install -m 755 drbdadm-83 $(DESTDIR)/lib/drbd/ ; \
++ install -g haclient -m 4750 drbdsetup-83 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
++ install -m 755 drbdadm-83 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
+ else \
+- install -m 755 drbdsetup-83 $(DESTDIR)/lib/drbd/ ; \
+- install -m 755 drbdadm-83 $(DESTDIR)/lib/drbd/ ; \
++ install -m 755 drbdsetup-83 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
++ install -m 755 drbdadm-83 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
+ fi
+ endif
+
+ uninstall:
+- rm -f $(DESTDIR)/lib/drbd/drbdsetup-83
+- rm -f $(DESTDIR)/lib/drbd/drbdadm-83
++ rm -f $(DESTDIR)/${nonarch_libdir}/drbd/drbdsetup-83
++ rm -f $(DESTDIR)/${nonarch_libdir}/drbd/drbdadm-83
+
+ .PHONY: install uninstall clean distclean
+ ../../configure:
+diff --git a/user/v84/Makefile.in b/user/v84/Makefile.in
+index 38977c6..05ef060 100644
+--- a/user/v84/Makefile.in
++++ b/user/v84/Makefile.in
+@@ -109,19 +109,19 @@ ifeq ($(WITH_84_SUPPORT),yes)
+ install -d $(DESTDIR)$(localstatedir)/lib/drbd
+ install -d $(DESTDIR)$(localstatedir)/run/drbd
+ install -d $(DESTDIR)$(localstatedir)/lock
+- install -d $(DESTDIR)/lib/drbd/
++ install -d $(DESTDIR)/${nonarch_libdir}/drbd/
+ if getent group haclient > /dev/null 2> /dev/null ; then \
+- install -g haclient -m 4750 drbdsetup-84 $(DESTDIR)/lib/drbd/ ; \
+- install -m 755 drbdadm-84 $(DESTDIR)/lib/drbd/ ; \
++ install -g haclient -m 4750 drbdsetup-84 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
++ install -m 755 drbdadm-84 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
+ else \
+- install -m 755 drbdsetup-84 $(DESTDIR)/lib/drbd/ ; \
+- install -m 755 drbdadm-84 $(DESTDIR)/lib/drbd/ ; \
++ install -m 755 drbdsetup-84 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
++ install -m 755 drbdadm-84 $(DESTDIR)/${nonarch_libdir}/drbd/ ; \
+ fi
+ endif
+
+ uninstall:
+- rm -f $(DESTDIR)/lib/drbd/drbdsetup-84
+- rm -f $(DESTDIR)/lib/drbd/drbdadm-84
++ rm -f $(DESTDIR)/${nonarch_libdir}/drbd/drbdsetup-84
++ rm -f $(DESTDIR)/${nonarch_libdir}/drbd/drbdadm-84
+
+ spell:
+ for f in drbdadm_adjust.c drbdadm_main.c drbdadm_parser.c drbdadm_usage_cnt.c drbdsetup.c drbdtool_common.c; do \
+--
+2.7.4
+
diff --git a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb
index bd1e8576..b83f68f8 100644
--- a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
+++ b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb
@@ -10,11 +10,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
- file://0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
+ ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-drbd-utils-support-usrmerge.patch','',d)} \
"
-# v9.5.0
-SRCREV_drbd-utils = "ee126652638328b55dc6bff47d07d6161ab768db"
-SRCREV_drbd-headers = "b47cc11bcabe1a65c40ad23f71dcaf2da6419630"
+# v9.12.0
+SRCREV_drbd-utils = "91629a4cce49ca0d4f917fe0bffa25cfe8db3052"
+SRCREV_drbd-headers = "233006b4d26cf319638be0ef6d16ec7dee287b66"
S = "${WORKDIR}/git"
@@ -23,6 +23,8 @@ UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
SYSTEMD_SERVICE_${PN} = "drbd.service"
SYSTEMD_AUTO_ENABLE = "disable"
+DEPENDS = "flex-native"
+
inherit autotools-brokensep systemd
EXTRA_OECONF = " \
@@ -36,20 +38,13 @@ EXTRA_OECONF = " \
--without-manual \
"
-do_configure_prepend() {
- # move the the file under folder /lib/drbd/ to /usr/lib/drbd when usrmerge enabled
- if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
- for m_file in `find ${S} -name 'Makefile.in'`; do
- sed -i -e "s;\$(DESTDIR)\/lib\/drbd;\$(DESTDIR)\${nonarch_libdir}\/drbd;g" $m_file
- done
- # move the the file under folder /lib/udev/ to /usr/lib/udev when usrmerge enabled
- sed -i -e "s;default_udevdir=/lib/udev;default_udevdir=\${prefix}/lib/udev;g" ${S}/configure.ac
- fi
+# If we have inherited reproducible_build, we want to use it.
+export WANT_DRBD_REPRODUCIBLE_BUILD = "yes"
-}
do_install_append() {
- # don't install empty /var/lock to avoid conflict with base-files
+ # don't install empty /var/lock and /var/run to avoid conflict with base-files
rm -rf ${D}${localstatedir}/lock
+ rm -rf ${D}${localstatedir}/run
}
RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
diff --git a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb
index fa4d10b4..23fe2021 100644
--- a/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb
+++ b/external/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb
@@ -9,10 +9,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
DEPENDS = "virtual/kernel"
SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
- file://check_existence_of_modules_before_installing.patch"
+ file://check_existence_of_modules_before_installing.patch \
+ "
+SRC_URI[md5sum] = "bd1202eaaf81641752d0c9b003b10f6c"
+SRC_URI[sha256sum] = "5b3d2bcb99542940e40af903dea783cf04524e9f41cc530e210d2c15ef84fa58"
-SRC_URI[md5sum] = "c1dd58043f46e9926b579aa65d4ea980"
-SRC_URI[sha256sum] = "87f72d46db9bad926415b3ab9f5f1397de8c581d2e2ec1addbdd5ce2604e6123"
inherit module
EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
@@ -21,4 +22,4 @@ do_install () {
oe_runmake install DESTDIR="${D}"
}
-PNBLACKLIST[drbd] = "implicit declaration of function 'setup_timer'; 4.15 head file issue?"
+PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+"