summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-support/ncp
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-support/ncp')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch44
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.32.bb (renamed from external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.31.bb)12
2 files changed, 52 insertions, 4 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch b/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch
new file mode 100644
index 00000000..6226e2c0
--- /dev/null
+++ b/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch
@@ -0,0 +1,44 @@
+From 7f6a104a682d59f28f7df889129f4467cc45e912 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 6 Nov 2019 19:55:42 -0800
+Subject: [PATCH] Depend on haveuint128.h for umult64.c
+
+This fixes parallel build issue e.g.
+mult/umult64.c:9:10: fatal error: 'haveuint128.h' file not found
+ ^~~~~~~~~~~~~~~
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ GNUmakefile | 1 +
+ Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/GNUmakefile b/GNUmakefile
+index 3f3193d..751ca60 100644
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -126,6 +126,7 @@ $(CDB_OBJS): cdb.h uint32.h
+ $(CRITBIT_OBJS): critbit.h
+
+ mult64.o: haveuint128.h
++umult64.o: haveuint128.h
+
+
+ iob_addbuf.o iob_addfile.o iob_new.o iob_reset.o iob_send.o: iob_internal.h iob.h
+diff --git a/Makefile b/Makefile
+index 0d08da4..02df6c6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -430,7 +430,7 @@ range_str4inbuf.o: mult/range_str4inbuf.c rangecheck.h
+ range_strinbuf.o: mult/range_strinbuf.c rangecheck.h
+ umult16.o: mult/umult16.c uint16.h
+ umult32.o: mult/umult32.c uint32.h
+-umult64.o: mult/umult64.c uint64.h
++umult64.o: mult/umult64.c uint64.h haveuint128.h
+ open_append.o: open/open_append.c open.h
+ open_excl.o: open/open_excl.c open.h
+ open_read.o: open/open_read.c open.h
+--
+2.24.0
+
diff --git a/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.31.bb b/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.32.bb
index 4b072f7e..d2f4df78 100644
--- a/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.31.bb
+++ b/external/meta-openembedded/meta-networking/recipes-support/ncp/libowfat_0.32.bb
@@ -6,9 +6,11 @@ HOMEPAGE = "http://www.fefe.de/libowfat"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-SRC_URI = "https://www.fefe.de/${BPN}/${BP}.tar.xz"
-SRC_URI[md5sum] = "120798fab86cfd72dc6b12284d248dd0"
-SRC_URI[sha256sum] = "d1e4ac1cfccbb7dc51d77d96398e6302d229ba7538158826c84cb4254c7e8a12"
+SRC_URI = "https://www.fefe.de/${BPN}/${BP}.tar.xz \
+ file://0001-Depend-on-haveuint128.h-for-umult64.c.patch \
+ "
+SRC_URI[md5sum] = "ee015ccf45cb2bc61c942642038c2bdc"
+SRC_URI[sha256sum] = "f4b9b3d9922dc25bc93adedf9e9ff8ddbebaf623f14c8e7a5f2301bfef7998c1"
EXTRA_OEMAKE = "\
DIET= \
@@ -19,9 +21,11 @@ EXTRA_OEMAKE = "\
do_install() {
make install \
DESTDIR=${D} \
- INCLUDEDIR=${includedir}/${BPN} \
+ INCLUDEDIR=${includedir} \
LIBDIR=${libdir} \
MAN3DIR=${mandir}/man3
}
+ALLOW_EMPTY_${PN} = "1"
+
BBCLASSEXTEND = "native nativesdk"