summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-support/nis
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-support/nis')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/nis/nis.inc2
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch45
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.6.bb (renamed from external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.4.bb)11
3 files changed, 52 insertions, 6 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-support/nis/nis.inc b/external/meta-openembedded/meta-networking/recipes-support/nis/nis.inc
index 200eaf74..a968af17 100644
--- a/external/meta-openembedded/meta-networking/recipes-support/nis/nis.inc
+++ b/external/meta-openembedded/meta-networking/recipes-support/nis/nis.inc
@@ -25,7 +25,7 @@ do_install() {
# so force the package to be skipped here (this will cause a
# 'nothing provides' error)
python () {
- os = d.getVar("TARGET_OS", True)
+ os = d.getVar("TARGET_OS")
if os == "linux-uclibc":
raise bb.parse.SkipRecipe("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
}
diff --git a/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch b/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch
new file mode 100644
index 00000000..9484d0b0
--- /dev/null
+++ b/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch
@@ -0,0 +1,45 @@
+From 25d5daf30aa2dc451ba528712f668036d8506054 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 27 Jul 2019 07:50:26 -0700
+Subject: [PATCH] Add configure time check for gettid API
+
+glibc 2.30 has added this syscalls wrapper
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 1 +
+ src/log_msg.c | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9e32a4a..6d1067b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,6 +33,7 @@ if test -n "$TIRPC_LIBS"; then
+ AC_DEFINE(HAVE_TIRPC, 1, [Define to 1 if TIRPC is available])
+ fi
+
++AC_CHECK_FUNCS(gettid)
+ dnl The difficult part: could we reconfigure NSS or must we use DNS ?
+ AC_CHECK_FUNCS(__nss_configure_lookup)
+ if eval "test \"`echo '$ac_cv_func___nss_configure_lookup'`\" != yes"; then
+diff --git a/src/log_msg.c b/src/log_msg.c
+index 49f0905..37da311 100644
+--- a/src/log_msg.c
++++ b/src/log_msg.c
+@@ -26,6 +26,7 @@
+ #include "log_msg.h"
+
+ #include <sys/syscall.h>
++#if !HAVE_GETTID
+ #ifdef __NR_gettid
+ static pid_t
+ gettid (void)
+@@ -39,6 +40,7 @@ gettid (void)
+ return getpid ();
+ }
+ #endif
++#endif
+
+ int debug_flag = 0;
+ int logfile_flag = 0;
diff --git a/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.4.bb b/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.6.bb
index 9822f455..03b98c9c 100644
--- a/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.4.bb
+++ b/external/meta-openembedded/meta-networking/recipes-support/nis/ypbind-mt_2.6.bb
@@ -16,7 +16,7 @@ the server which answered as first. \
\
This is the final IPv4-only version of ypbind-mt. \
"
-HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
+HOMEPAGE = "https://github.com/thkukuk/ypbind-mt/"
DEPENDS = " \
yp-tools \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
@@ -28,13 +28,14 @@ RDEPENDS_${PN} += "yp-tools"
# and is used in place of it.
PROVIDES += "ypbind"
-SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
+SRC_URI = "https://github.com/thkukuk/ypbind-mt/releases/download/v${PV}/${BPN}-${PV}.tar.xz \
file://ypbind.init \
file://ypbind.service \
file://0001-dns_hosts-Fix-build-with-musl.patch \
+ file://0001-Add-configure-time-check-for-gettid-API.patch \
"
-SRC_URI[md5sum] = "1aeccd0d11c064d5d59c56941bca682b"
-SRC_URI[sha256sum] = "a2e1fa8fc992a12b289c229e00e38c20d59070c3bcf08babf40c692515c340e0"
+SRC_URI[md5sum] = "7cf89641fdc128d0919207e4b7caaf1d"
+SRC_URI[sha256sum] = "0696c0263c4fd48a4ff2ce6c109f05f37aab0f71646d81cb22c7c28591bf80eb"
inherit systemd update-rc.d
@@ -44,7 +45,7 @@ INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
-CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/nss3"
+CFLAGS_append = " -I${STAGING_INCDIR}/nss3 -I${STAGING_INCDIR}/nspr"
do_install_append () {
install -d ${D}${sysconfdir}/init.d