summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/libgpiod
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/libgpiod')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod.inc9
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb4
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.4.3.bb (renamed from external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb)15
3 files changed, 16 insertions, 12 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod.inc b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod.inc
index cd775062..07ce35a7 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod.inc
+++ b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod.inc
@@ -7,15 +7,10 @@ SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
inherit autotools pkgconfig
-# enable tools
-PACKAGECONFIG ?= "tools"
-
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
-PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+EXTRA_OECONF = "--enable-tools"
PACKAGES =+ " ${PN}-tools"
FILES_${PN}-tools = "${bindir}/*"
-
-RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
-RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"
diff --git a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
index 09fb65a0..c4d2bddf 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
@@ -1,4 +1,8 @@
require libgpiod.inc
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+
SRC_URI[md5sum] = "2aa1e1a80c3c919ae142ab9a55fb59ca"
SRC_URI[sha256sum] = "b773e557af1a497f786825462a776b7bf90168e67ee0a5bc5d2473a5674dc38c"
diff --git a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.4.3.bb
index 30289b98..a6320da8 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.4.3.bb
@@ -2,15 +2,20 @@ require libgpiod.inc
DEPENDS += "autoconf-archive-native"
-SRC_URI[md5sum] = "34a9972f2f4e9c32fa940301301b007d"
-SRC_URI[sha256sum] = "b6b9079c933f7c8524815437937dda6b795a16141bca202a9eec70ba5844b5ba"
+SRC_URI[md5sum] = "d4826720a8de13379436f9c207237bc0"
+SRC_URI[sha256sum] = "0ad080d1eb89c422cf13001293ffa72869ca13028e85dab5f6b3ba90f88da46d"
+
+# enable cxx bindings
+PACKAGECONFIG ?= "cxx"
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+
+PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
-PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3,python3-core"
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}
+inherit python3native
PACKAGES =+ "${PN}-python"
FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
-RRECOMMENDS_${PN} += "${RRECOMMENDS_PYTHON}"
+RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"