summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/lio-utils
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/lio-utils')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch61
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb66
2 files changed, 127 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch b/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch
new file mode 100644
index 00000000..9608b7e7
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch
@@ -0,0 +1,61 @@
+From 2cc2315eecaa48fd24792aaa889dc7d9fb96978b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 20 Mar 2017 22:18:44 -0700
+Subject: [PATCH] Makefiles: Respect environment variables and add LDFLAGS to
+ linker cmdline
+
+Fixes QA errors about GNU_HASH
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mib-modules/Makefile | 10 +++++-----
+ tools/Makefile | 2 +-
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/mib-modules/Makefile b/mib-modules/Makefile
+index 0d54c9b..051d4d2 100644
+--- a/mib-modules/Makefile
++++ b/mib-modules/Makefile
+@@ -17,13 +17,13 @@ TARG = iscsiTargetMib.so
+ OBJS = iscsiTargetMib.o iscsiMib.o scsiMib.o ipsAuthMib.o \
+ iscsiAuthData.o
+
+-CC = gcc
+-CFLAGS = -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC
++CC ?= gcc
++CFLAGS += -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC
+ CFLAGS += -I../include -Wall -Werror
+ #CFLAGS +=$(AUTO_CFLAGS)
+
+-LD = gcc -shared
+-
++LD ?= gcc
++LDFLAGS += -shared
+ INSTALL = install
+
+ all: $(TARG)
+@@ -32,7 +32,7 @@ all: $(TARG)
+ $(CC) $(CFLAGS) -o $@ -c $<
+
+ $(TARG): $(OBJS)
+- $(LD) -o $@ $(OBJS)
++ $(LD) -o $@ $(OBJS) $(LDFLAGS)
+
+ clean:
+ rm -f $(OBJS) $(TARG)
+diff --git a/tools/Makefile b/tools/Makefile
+index 79ed3cd..ffd9bf3 100644
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -6,7 +6,7 @@ ISCSI_NAME_OBJS = $(ISCSI_NAME_SRCS:.c=.o)
+ all:: $(ISCSI_NAME)
+
+ $(ISCSI_NAME): $(ISCSI_NAME_OBJS)
+- $(CC) -o $@ $(CFLAGS) $(ISCSI_NAME_OBJS)
++ $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(ISCSI_NAME_OBJS)
+
+ clean:
+ rm -f $(ISCSI_NAME_OBJS) $(ISCSI_NAME)
+--
+2.12.0
+
diff --git a/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
new file mode 100644
index 00000000..d9780cfb
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
@@ -0,0 +1,66 @@
+SUMMARY = "lio-utils"
+DESCRIPTION = "a simple low-level configuration tool set for the Target+iSCSI (LIO)"
+HOMEPAGE = "http://linux-iscsi.org/index.php/Lio-utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df"
+
+PV = "4.1+git${SRCPV}"
+
+SRC_URI = "git://risingtidesystems.com/lio-utils.git \
+ file://0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch \
+ "
+SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+EXTRA_OEMAKE += "DESTDIR=${D}"
+
+do_compile() {
+ cd ${S}/tcm-py
+ distutils_do_compile
+
+ cd ${S}/lio-py
+ distutils_do_compile
+
+ if test -d ${S}/tools; then
+ oe_runmake -C ${S}/tools
+ fi
+}
+
+do_install() {
+ cd ${S}/tcm-py
+ distutils_do_install
+
+ cd ${S}/lio-py
+ distutils_do_install
+
+ SITE_PACKAGES=${D}/${PYTHON_SITEPACKAGES_DIR}
+ install -d ${D}/${sbindir}
+ for var in tcm_node tcm_dump tcm_loop tcm_fabric lio_dump lio_node; do
+ if [ ! -h ${D}/${sbindir}/${var} ];then
+ chmod a+x ${SITE_PACKAGES}/${var}.py
+ ln -s ${PYTHON_SITEPACKAGES_DIR}/${var}.py ${D}/${sbindir}/${var}
+ fi
+ done
+
+ if test -d ${S}/tools; then
+ oe_runmake -C ${S}/tools install
+ fi
+
+ install -d ${D}/etc/target/
+ install -d ${D}/etc/init.d/
+ install -m 755 ${S}/scripts/rc.target ${D}/etc/init.d/
+ install -m 755 ${S}/conf/tcm_start.default ${D}/etc/target/tcm_start.sh
+ install -m 755 ${S}/conf/lio_start.default ${D}/etc/target/lio_start.sh
+}
+
+RDEPENDS_${PN} += "python-stringold python-subprocess python-shell \
+ python-datetime python-textutils python-crypt python-netclient python-email \
+ bash"
+
+FILES_${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*"
+
+# http://errors.yoctoproject.org/Errors/Details/184712/
+# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
+CLEANBROKEN = "1"