summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-perl/recipes-perl/libhtml
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-perl/recipes-perl/libhtml')
-rw-r--r--external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb22
-rw-r--r--external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb29
2 files changed, 50 insertions, 1 deletions
diff --git a/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb b/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
index e202de05..a4c69c97 100644
--- a/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
+++ b/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
@@ -16,10 +16,30 @@ S = "${WORKDIR}/HTML-Parser-${PV}"
EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
-inherit cpan
+inherit cpan ptest-perl
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile
}
+
+RDEPENDS_${PN} += "\
+ perl-module-exporter \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-xsloader \
+ libhtml-tagset-perl \
+"
+
+RDEPENDS_${PN}-ptest += "\
+ liburi-perl \
+ perl-module-config \
+ perl-module-file-spec \
+ perl-module-filehandle \
+ perl-module-io-file \
+ perl-module-selectsaver \
+ perl-module-test \
+ perl-module-test-more \
+"
+
BBCLASSEXTEND = "native"
diff --git a/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb b/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb
new file mode 100644
index 00000000..d6483cc5
--- /dev/null
+++ b/external/meta-openembedded/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb
@@ -0,0 +1,29 @@
+SUMMARY = "HTML::Tageset - data tables useful in parsing HTML"
+DESCRIPTION = "This module contains several data tables useful in various \
+kinds of HTML parsing operations."
+HOMEPAGE = "https://metacpan.org/release/HTML-Tagset"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://README;beginline=62;endline=66;md5=aa91eed6adfe182d2af676954f06a7c9"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PE/PETDANCE/HTML-Tagset-${PV}.tar.gz"
+SRC_URI[md5sum] = "d2bfa18fe1904df7f683e96611e87437"
+SRC_URI[sha256sum] = "adb17dac9e36cd011f5243881c9739417fd102fce760f8de4e9be4c7131108e2"
+
+S = "${WORKDIR}/HTML-Tagset-${PV}"
+
+
+inherit cpan ptest-perl
+
+
+RDEPENDS_${PN} += "perl-module-strict perl-module-vars"
+
+RDEPENDS_${PN}-ptest += "perl-module-test"
+
+do_install_prepend() {
+ # requires "-T" (taint) command line option
+ rm -rf ${B}/t/pod.t
+}
+
+BBCLASSEXTEND = "native"