summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-connectivity/python-h2
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-connectivity/python-h2')
-rw-r--r--external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc12
-rw-r--r--external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb3
2 files changed, 15 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc b/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
new file mode 100644
index 00000000..c457836b
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE = "https://github.com/python-hyper/hyper-h2"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b6b2f6bbe76528af543242d606c14851"
+
+SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
+SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-hpack ${PYTHON_PN}-hyperframe"
diff --git a/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb b/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
new file mode 100644
index 00000000..7230a27e
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
@@ -0,0 +1,3 @@
+require python-h2.inc
+
+inherit setuptools3