summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb b/external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb
new file mode 100644
index 00000000..7249058f
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-decorator_4.4.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python decorator utilities"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+HOMEPAGE = "https://github.com/micheles/decorator"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
+
+SRC_URI[md5sum] = "933981f288c4230816b5beee8d40e6ea"
+SRC_URI[sha256sum] = "54c38050039232e1db4ad7375cfce6748d7b41c29e95a081c8a6d2c30364a2ce"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-stringold \
+ "