summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb b/external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb
new file mode 100644
index 00000000..2d7aae6b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-feedformatter_0.4.bb
@@ -0,0 +1,25 @@
+SUMMARY = "A Python library for generating news feeds in RSS and Atom formats"
+DESCRIPTION = "feedformatter is intended to be in many ways an "opposite" to \
+the well-known and well-loved Python module feedparser. Whereas feedparser \
+tries to turn any news feed in any format into a friendly data structure of \
+lists and dictionaries, feedformatter tries to turn a friendly data structure \
+of lists and dictionaries into a well-formatted news feed of whatever kind you \
+like."
+HOMEPAGE = "http://code.google.com/p/feedformatter/"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d"
+
+SRC_URI = "git://github.com/marianoguerra/feedformatter.git"
+SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-xml \
+ "