summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb b/external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb
new file mode 100644
index 00000000..5201788d
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pycryptodomex_3.9.4.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Cryptographic library for Python"
+DESCRIPTION = "PyCryptodome is a self-contained Python package of low-level\
+ cryptographic primitives."
+HOMEPAGE = "http://www.pycryptodome.org"
+LICENSE = "PD & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=6dc0e2a13d2f25d6f123c434b761faba"
+
+SRC_URI[md5sum] = "46ba513d95b6e323734074d960a7d57b"
+SRC_URI[sha256sum] = "22d970cee5c096b9123415e183ae03702b2cd4d3ba3f0ced25c4e1aba3967167"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-math \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PYTHON_PN}-unittest \
+"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/ \
+ ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/__pycache__/ \
+"
+
+BBCLASSEXTEND = "native nativesdk"