summaryrefslogtreecommitdiffstats
path: root/external/meta-qt5/recipes-qt/maliit
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-qt5/recipes-qt/maliit')
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch83
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch62
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-examples-plugins-Replace-obsolete-screenGeometry.patch66
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5_git.bb3
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5/0001-Do-not-use-tr1-namespace.patch58
-rw-r--r--external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5_git.bb4
6 files changed, 275 insertions, 1 deletions
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch
new file mode 100644
index 00000000..920946ec
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch
@@ -0,0 +1,83 @@
+From 60e7464fe2b75bb7187a4be0d6ba944d2b46f93e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 31 Jan 2019 22:02:32 -0800
+Subject: [PATCH] Drop tr1 namespace its not there in c++11 and newer
+
+compile as C++11 code
+libc++'s tr1 headers don't actually make a tr1 namespace.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/mimonscreenplugins.cpp | 10 +++++-----
+ .../ut_mimpluginmanagerconfig.cpp | 2 +-
+ .../ut_mimpluginmanagerconfig.h | 2 +-
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/mimonscreenplugins.cpp b/src/mimonscreenplugins.cpp
+index da6e937e..b830e1bf 100644
+--- a/src/mimonscreenplugins.cpp
++++ b/src/mimonscreenplugins.cpp
+@@ -21,9 +21,9 @@
+ #include <QDebug>
+
+ #include <algorithm>
+-#include <tr1/functional>
++#include <functional>
+
+-using namespace std::tr1::placeholders;
++using namespace std::placeholders;
+
+ namespace
+ {
+@@ -118,10 +118,10 @@ bool MImOnScreenPlugins::isEnabled(const QString &plugin) const
+
+ std::remove_copy_if(mEnabledSubViews.begin(), mEnabledSubViews.end(),
+ std::back_inserter(mEnabledAndAvailableSubViews),
+- std::tr1::bind(&MImOnScreenPlugins::isSubViewUnavailable, this, _1));
++ std::bind(&MImOnScreenPlugins::isSubViewUnavailable, this, _1));
+
+ return std::find_if(mEnabledAndAvailableSubViews.begin(), mEnabledAndAvailableSubViews.end(),
+- std::tr1::bind(equalPlugin, _1, plugin)) != mEnabledAndAvailableSubViews.end();
++ std::bind(equalPlugin, _1, plugin)) != mEnabledAndAvailableSubViews.end();
+ }
+
+ bool MImOnScreenPlugins::isSubViewEnabled(const SubView &subView) const
+@@ -138,7 +138,7 @@ QList<MImOnScreenPlugins::SubView> MImOnScreenPlugins::enabledSubViews(const QSt
+ {
+ QList<MImOnScreenPlugins::SubView> result;
+ std::remove_copy_if(mEnabledSubViews.begin(), mEnabledSubViews.end(),
+- std::back_inserter(result), std::tr1::bind(notEqualPlugin, _1, plugin));
++ std::back_inserter(result), std::bind(notEqualPlugin, _1, plugin));
+ return result;
+ }
+
+diff --git a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.cpp b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.cpp
+index dea443e3..677dd689 100644
+--- a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.cpp
++++ b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.cpp
+@@ -39,7 +39,7 @@
+ #include "mattributeextensionmanager.h"
+ #include "msharedattributeextensionmanager.h"
+
+-using namespace std::tr1;
++using namespace std;
+
+ typedef QSet<Maliit::HandlerState> HandlerStates;
+ Q_DECLARE_METATYPE(HandlerStates);
+diff --git a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.h b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.h
+index 5b1b691b..3ea18747 100644
+--- a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.h
++++ b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.h
+@@ -16,7 +16,7 @@
+
+ #include "mimserveroptions.h"
+ #include "mimsettingsqsettings.h"
+-#include <tr1/memory>
++#include <memory>
+
+ #include <QtTest/QtTest>
+ #include <QObject>
+--
+2.20.1
+
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch
new file mode 100644
index 00000000..d86be1e1
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch
@@ -0,0 +1,62 @@
+From 78a4b12b64c26f29e64fe56801e92d1e76f362b0 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Fri, 16 Aug 2019 15:08:41 +0300
+Subject: [PATCH] Fix test installations
+
+Qmake won't ignore install errors anymore.
+
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ .../ut_mattributeextensionmanager.pro | 7 ++++---
+ tests/ut_mimpluginmanager/ut_mimpluginmanager.pro | 7 ++++---
+ .../ut_mimpluginmanagerconfig.pro | 3 ---
+ 3 files changed, 8 insertions(+), 9 deletions(-)
+
+diff --git a/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro b/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro
+index 22280882..d0c390ef 100644
+--- a/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro
++++ b/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro
+@@ -13,9 +13,10 @@ CONFIG += plugin
+ include($$TOP_DIR/src/libmaliit-plugins.pri)
+ include($$TOP_DIR/connection/libmaliit-connection.pri)
+
+-target.files += \
+- $$TARGET \
++extra.files += \
+ toolbar1.xml \
+- toolbar2.xml \
++ toolbar2.xml
++extra.path = $$target.path
++INSTALLS += extra
+
+ include(../common_check.pri)
+diff --git a/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro b/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro
+index 19e68e6a..44e0fa0f 100644
+--- a/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro
++++ b/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro
+@@ -17,9 +17,10 @@ include($$TOP_DIR/src/libmaliit-plugins.pri)
+ # For MImInputContextConnection pulled in by TestInputMethodHost
+ include($$TOP_DIR/connection/libmaliit-connection.pri)
+
+-target.files += \
+- $$TARGET \
++extra.files += \
+ toolbar1.xml \
+- toolbar2.xml \
++ toolbar2.xml
++extra.path = $$target.path
++INSTALLS += extra
+
+ include(../common_check.pri)
+diff --git a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro
+index 739ceef6..e0b363c8 100644
+--- a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro
++++ b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro
+@@ -17,7 +17,4 @@ include($$TOP_DIR/src/libmaliit-plugins.pri)
+ # For MImInputContextConnection pulled in by TestInputMethodHost
+ include($$TOP_DIR/connection/libmaliit-connection.pri)
+
+-target.files += \
+- $$TARGET \
+-
+ include(../common_check.pri)
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-examples-plugins-Replace-obsolete-screenGeometry.patch b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-examples-plugins-Replace-obsolete-screenGeometry.patch
new file mode 100644
index 00000000..84c8aeac
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5/0001-examples-plugins-Replace-obsolete-screenGeometry.patch
@@ -0,0 +1,66 @@
+From 604761d49aa1d93ef5cc6d13259dc53dce7f04c4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 16 Jul 2019 17:52:04 -0700
+Subject: [PATCH] examples/plugins: Replace obsolete screenGeometry
+
+Fixes errors like
+helloworldinputmethod.cpp:93:55: error: 'screenGeometry' is deprecated: Use QGuiApplication::screens() [-Werror,-Wdeprecated-declarations]
+ const QSize screenSize = QApplication::desktop()->screenGeometry().size();
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ examples/plugins/cxx/helloworld/helloworldinputmethod.cpp | 5 +++--
+ examples/plugins/cxx/override/overrideinputmethod.cpp | 5 +++--
+ 2 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/examples/plugins/cxx/helloworld/helloworldinputmethod.cpp b/examples/plugins/cxx/helloworld/helloworldinputmethod.cpp
+index eb470a1f..e5e5911d 100644
+--- a/examples/plugins/cxx/helloworld/helloworldinputmethod.cpp
++++ b/examples/plugins/cxx/helloworld/helloworldinputmethod.cpp
+@@ -18,7 +18,7 @@
+
+ #include <QDebug>
+ #include <QApplication>
+-#include <QDesktopWidget>
++#include <QScreen>
+
+ namespace {
+
+@@ -90,7 +90,8 @@ void HelloWorldInputMethod::show()
+ }
+
+ // Set size of our container to screen size
+- const QSize screenSize = QApplication::desktop()->screenGeometry().size();
++ QScreen *screen = QApplication::primaryScreen();
++ const QSize screenSize = screen->availableSize();
+ mainWidget->parentWidget()->resize(screenSize);
+
+ // Set size of the input method
+diff --git a/examples/plugins/cxx/override/overrideinputmethod.cpp b/examples/plugins/cxx/override/overrideinputmethod.cpp
+index c00160e4..f2f30e1d 100644
+--- a/examples/plugins/cxx/override/overrideinputmethod.cpp
++++ b/examples/plugins/cxx/override/overrideinputmethod.cpp
+@@ -18,7 +18,7 @@
+
+ #include <QDebug>
+ #include <QApplication>
+-#include <QDesktopWidget>
++#include <QScreen>
+ #include <QKeyEvent>
+
+ namespace {
+@@ -82,7 +82,8 @@ void OverrideInputMethod::show()
+ }
+
+ // Set size of the input method
+- const QSize &screenSize = QApplication::desktop()->screenGeometry().size();
++ QScreen *screen = QApplication::primaryScreen();
++ const QSize screenSize = screen->availableSize();
+ const QSize size(screenSize.width() - 200, 200);
+
+ surface->setGeometry(QRect(QPoint((screenSize.width() - size.width()) / 2,
+--
+2.22.0
+
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5_git.bb b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 232e8252..1f0dc8d6 100644
--- a/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -10,6 +10,9 @@ SRC_URI = "git://github.com/maliit/framework.git;branch=master \
file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
file://maliit-server.desktop \
file://0001-config.pri-Use-O1-optimization-in-DEBUG-flags.patch \
+ file://0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch \
+ file://0001-examples-plugins-Replace-obsolete-screenGeometry.patch \
+ file://0001-Fix-test-installations.patch \
"
SRCREV = "60b1b10de14f932420313c547ab801daf522d539"
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5/0001-Do-not-use-tr1-namespace.patch b/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5/0001-Do-not-use-tr1-namespace.patch
new file mode 100644
index 00000000..e5525379
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5/0001-Do-not-use-tr1-namespace.patch
@@ -0,0 +1,58 @@
+From 19cc10dc4378e9eda15b58f3673f686c4ff845e2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 31 Jan 2019 22:17:56 -0800
+Subject: [PATCH] Do not use tr1 namespace
+
+This is not a standard in C++11
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ maliit-keyboard/lib/logic/layouthelper.cpp | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/maliit-keyboard/lib/logic/layouthelper.cpp b/maliit-keyboard/lib/logic/layouthelper.cpp
+index a8bd995f..f694e819 100644
+--- a/maliit-keyboard/lib/logic/layouthelper.cpp
++++ b/maliit-keyboard/lib/logic/layouthelper.cpp
+@@ -31,7 +31,7 @@
+ */
+
+ #include <algorithm>
+-#include <tr1/functional>
++#include <functional>
+
+ #include "layouthelper.h"
+ #include "coreutils.h"
+@@ -76,7 +76,7 @@ struct KeyPredicate
+
+ } // namespace
+
+-typedef std::tr1::function<void(const KeyArea &, const KeyOverrides &)> EmitFunc;
++typedef std::function<void(const KeyArea &, const KeyOverrides &)> EmitFunc;
+
+ class LayoutHelperPrivate
+ {
+@@ -468,13 +468,13 @@ void LayoutHelper::onKeysOverriden(const KeyOverrides &overriden_keys,
+ d->overriden_keys = overriden_keys;
+ }
+
+- using std::tr1::placeholders::_1;
+- using std::tr1::placeholders::_2;
++ using std::placeholders::_1;
++ using std::placeholders::_2;
+
+- d->overrideCheck(changed_ids, d->left, std::tr1::bind(&LayoutHelper::leftPanelChanged, this, _1, _2));
+- d->overrideCheck(changed_ids, d->right, std::tr1::bind(&LayoutHelper::rightPanelChanged, this, _1, _2));
+- d->overrideCheck(changed_ids, d->center, std::tr1::bind(&LayoutHelper::centerPanelChanged, this, _1, _2));
+- d->overrideCheck(changed_ids, d->extended, std::tr1::bind(&LayoutHelper::extendedPanelChanged, this, _1, _2));
++ d->overrideCheck(changed_ids, d->left, std::bind(&LayoutHelper::leftPanelChanged, this, _1, _2));
++ d->overrideCheck(changed_ids, d->right, std::bind(&LayoutHelper::rightPanelChanged, this, _1, _2));
++ d->overrideCheck(changed_ids, d->center, std::bind(&LayoutHelper::centerPanelChanged, this, _1, _2));
++ d->overrideCheck(changed_ids, d->extended, std::bind(&LayoutHelper::extendedPanelChanged, this, _1, _2));
+ }
+
+ }} // namespace Logic, MaliitKeyboard
+--
+2.20.1
+
diff --git a/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index 8225cb54..8464e1f0 100644
--- a/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/external/meta-qt5/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -10,7 +10,9 @@ DEPENDS = "maliit-framework-qt5"
RDEPENDS_${PN} += "qtsvg-plugins"
-SRC_URI = "git://github.com/maliit/plugins.git;branch=master"
+SRC_URI = "git://github.com/maliit/plugins.git;branch=master \
+ file://0001-Do-not-use-tr1-namespace.patch \
+ "
SRCREV = "c6a348592607248a771a3dde5a0e33dc3c433a2a"
PV = "0.99.0+git${SRCPV}"