summaryrefslogtreecommitdiffstats
path: root/external/meta-spdxscanner/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-spdxscanner/recipes-support')
-rw-r--r--external/meta-spdxscanner/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch43
-rw-r--r--external/meta-spdxscanner/recipes-support/postgresql/postgresql-native_9.4.11.bb91
2 files changed, 0 insertions, 134 deletions
diff --git a/external/meta-spdxscanner/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch b/external/meta-spdxscanner/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch
deleted file mode 100644
index d08ec6af..00000000
--- a/external/meta-spdxscanner/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From d52e330be895bb8c5f0fb3e2884766acbd942a85 Mon Sep 17 00:00:00 2001
-From: Philip Balister <philip@balister.org>
-Date: Tue, 1 Jul 2014 09:40:44 -0400
-Subject: [PATCH] Use pkg-config for libxml2 detection.
-
-Upstream-Status: Inappropriate [configuration]
-
-xml2-config does not work. Use pkgconfig to set CPPFLAGS and LIBS.
-
-Signed-off-by: Philip Balister <philip@balister.org>
----
- configure.in | 15 ++-------------
- 1 file changed, 2 insertions(+), 13 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index f8bf466..1f4fabf 100644
---- a/configure.in
-+++ b/configure.in
-@@ -734,19 +734,8 @@ PGAC_ARG_BOOL(with, libxml, no, [build with XML support],
- [AC_DEFINE([USE_LIBXML], 1, [Define to 1 to build with XML support. (--with-libxml)])])
-
- if test "$with_libxml" = yes ; then
-- AC_CHECK_PROGS(XML2_CONFIG, xml2-config)
-- if test -n "$XML2_CONFIG"; then
-- for pgac_option in `$XML2_CONFIG --cflags`; do
-- case $pgac_option in
-- -I*|-D*) CPPFLAGS="$CPPFLAGS $pgac_option";;
-- esac
-- done
-- for pgac_option in `$XML2_CONFIG --libs`; do
-- case $pgac_option in
-- -L*) LDFLAGS="$LDFLAGS $pgac_option";;
-- esac
-- done
-- fi
-+ CPPFLAGS="$CPPFLAGS `pkg-config --short-errors --print-errors --cflags "libxml-2.0" 2>&1`"
-+ LIBS="`pkg-config --short-errors --print-errors --libs "libxml-2.0" 2>&1` $LIBS"
- fi
-
- AC_SUBST(with_libxml)
---
-1.8.3.1
-
diff --git a/external/meta-spdxscanner/recipes-support/postgresql/postgresql-native_9.4.11.bb b/external/meta-spdxscanner/recipes-support/postgresql/postgresql-native_9.4.11.bb
deleted file mode 100644
index 0bd69908..00000000
--- a/external/meta-spdxscanner/recipes-support/postgresql/postgresql-native_9.4.11.bb
+++ /dev/null
@@ -1,91 +0,0 @@
-SUMMARY = "PostgreSQL is a powerful, open source relational database system."
-DESCRIPTION = "\
- PostgreSQL is an advanced Object-Relational database management system \
- (DBMS) that supports almost all SQL constructs (including \
- transactions, subselects and user-defined types and functions). The \
- postgresql package includes the client programs and libraries that \
- you'll need to access a PostgreSQL DBMS server. These PostgreSQL \
- client programs are programs that directly manipulate the internal \
- structure of PostgreSQL databases on a PostgreSQL server. These client \
- programs can be located on the same machine with the PostgreSQL \
- server, or may be on a remote machine which accesses a PostgreSQL \
- server over a network connection. This package contains the docs \
- in HTML for the whole package, as well as command-line utilities for \
- managing PostgreSQL databases on a PostgreSQL server. \
- \
- If you want to manipulate a PostgreSQL database on a local or remote \
- PostgreSQL server, you need this package. You also need to install \
- this package if you're installing the postgresql-server package. \
-"
-HOMEPAGE = "http://www.postgresql.com"
-LICENSE = "BSD"
-DEPENDS = "tcl-native libxml2-native libxslt-native perl-native"
-
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=81b69ddb31a8be66baafd14a90146ee2"
-
-SRC_URI[md5sum] = "2fee03f2034034dbfcb3321a0bb0f829"
-SRC_URI[sha256sum] = "e3eb51d045c180b03d2de1f0c3af9356e10be49448e966ca01dfc2c6d1cc9d23"
-
-SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \
- file://0001-Use-pkg-config-for-libxml2-detection.patch \
-"
-
-LEAD_SONAME = "libpq.so"
-
-# LDFLAGS for shared libraries
-export LDFLAGS_SL = "${LDFLAGS}"
-
-inherit autotools-brokensep pkgconfig perlnative native python3-dir
-
-CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"
-
-EXTRA_OECONF = " --with-tclconfig=${STAGING_LIBDIR_NATIVE} \
- --with-includes=${STAGING_INCDIR_NATIVE}/tcl${TCL_VER} \
-"
-
-EXTRA_OECONF_append = " \
- --with-tcl --with-openssl --with-perl \
- --with-libxml --with-libxslt \
- ${COMMON_CONFIGURE_FLAGS} \
-"
-
-do_configure_append() {
- test -d build_py3 || mkdir build_py3
- cd build_py3
- ../configure --host=${HOST_SYS} \
- --build=${BUILD_SYS} \
- --target=${TARGET_SYS} \
- ${COMMON_CONFIGURE_FLAGS}
- cd ${S}
-}
-
-do_compile_append() {
- oe_runmake -C contrib all
- cd build_py3
- #cp ${S}/src/pl/plpython/*.o ${S}/build_py3/src/pl/plpython
- oe_runmake -C src/backend/ submake-errcodes
- oe_runmake -C src/pl/plpython
-}
-
-# server needs to configure user and group
-usernum = "28"
-groupnum = "28"
-USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "-M -g postgres -o -r -d ${localstatedir}/lib/${BPN} \
- -s /bin/bash -c 'PostgreSQL Server' -u ${usernum} postgres"
-GROUPADD_PARAM_${PN} = "-g ${groupnum} -o -r postgres"
-
-do_install_append() {
- # Follow Deian, some files belong to /usr/bin
- install -d ${D}${bindir}
- oe_runmake -C ${S}/contrib install DESTDIR=${D}
- install -m 0644 ${S}/src/pl/plpython/plpython3u* \
- ${D}${datadir}/${MAJOR_VER}/extension/
- #install -m 0755 ${S}/build_py3/src/pl/plpython/plpython3.so ${D}${libdir}/${MAJOR_VER}/lib
-
- # Remove the the absolute path to sysroot
- sed -i -e "s|${STAGING_LIBDIR}|${libdir}|" \
- ${D}${libdir}/pkgconfig/*.pc
-}
-
-SSTATE_SCAN_FILES += "Makefile.global"