summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb')
-rw-r--r--external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb
index d3d6f165..2ee47a16 100644
--- a/external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb
+++ b/external/meta-updater/recipes-sota/aktualizr/aktualizr-shared-prov.bb
@@ -7,15 +7,18 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
inherit allarch
-DEPENDS = "aktualizr-native zip-native"
+# We need to get the config files from the aktualizr-host-tools package built by
+# the aktualizr (target) recipe.
+DEPENDS = "aktualizr"
RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}"
+
+# If the config file from aktualizr used here is changed, you will need to bump
+# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
PV = "1.0"
PR = "6"
SRC_URI = ""
-require credentials.inc
-
do_install() {
if [ -n "${SOTA_AUTOPROVISION_CREDENTIALS}" ]; then
bbwarn "SOTA_AUTOPROVISION_CREDENTIALS are ignored. Please use SOTA_PACKED_CREDENTIALS"
@@ -31,7 +34,7 @@ do_install() {
fi
install -m 0700 -d ${D}${libdir}/sota/conf.d
- install -m 0644 ${STAGING_DIR_NATIVE}${libdir}/sota/sota-shared-cred.toml \
+ install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-shared-cred.toml \
${D}${libdir}/sota/conf.d/20-sota-shared-cred.toml
}