summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb')
-rw-r--r--external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb b/external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb
new file mode 100644
index 00000000..d74cf247
--- /dev/null
+++ b/external/meta-updater/recipes-sota/ostree/ostree-booted_1.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Indicate an OSTree boot"
+DESCRIPTION = "Indicate an OSTree boot"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+SRC_URI = "file://touch-ostree"
+
+inherit allarch update-rc.d
+
+INITSCRIPT_NAME = "touch-ostree"
+INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/touch-ostree ${D}${sysconfdir}/init.d/touch-ostree
+}