summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater/recipes-support')
-rw-r--r--external/meta-updater/recipes-support/boost/boost_1.72.0.bbappend4
-rw-r--r--external/meta-updater/recipes-support/boost/files/0001-add-typedef-executor_type.patch56
-rw-r--r--external/meta-updater/recipes-support/libp11/libp11_git.bb40
-rw-r--r--external/meta-updater/recipes-support/softhsm-testtoken/softhsm-testtoken.bb2
4 files changed, 61 insertions, 41 deletions
diff --git a/external/meta-updater/recipes-support/boost/boost_1.72.0.bbappend b/external/meta-updater/recipes-support/boost/boost_1.72.0.bbappend
new file mode 100644
index 00000000..73ee73d7
--- /dev/null
+++ b/external/meta-updater/recipes-support/boost/boost_1.72.0.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://0001-add-typedef-executor_type.patch \
+ "
diff --git a/external/meta-updater/recipes-support/boost/files/0001-add-typedef-executor_type.patch b/external/meta-updater/recipes-support/boost/files/0001-add-typedef-executor_type.patch
new file mode 100644
index 00000000..1b326a49
--- /dev/null
+++ b/external/meta-updater/recipes-support/boost/files/0001-add-typedef-executor_type.patch
@@ -0,0 +1,56 @@
+From 99ad3ebac0b7466d57c98fb9583fbe8789729691 Mon Sep 17 00:00:00 2001
+From: Patrick Vacek <patrickvacek@gmail.com>
+Date: Wed, 4 Mar 2020 12:41:02 +0000
+Subject: [PATCH] add typedef executor_type
+
+Backported from here:
+https://github.com/boostorg/process/commit/6a4d2ff72114ef47c7afaf92e1042aca3dfa41b0
+
+Suggested-by: Kostiantyn Bushko <kbushko@intellias.com>
+Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
+---
+ boost/process/async_pipe.hpp | 2 ++
+ boost/process/detail/posix/async_pipe.hpp | 1 +
+ boost/process/detail/windows/async_pipe.hpp | 1 +
+ 3 files changed, 4 insertions(+)
+
+diff --git a/boost/process/async_pipe.hpp b/boost/process/async_pipe.hpp
+index 101fe1d..a562432 100644
+--- a/boost/process/async_pipe.hpp
++++ b/boost/process/async_pipe.hpp
+@@ -47,6 +47,8 @@ public:
+ */
+ typedef platform_specific handle_type;
+
++ typedef typename handle_type::executor_type executor_type;
++
+ /** Construct a new async_pipe, does automatically open the pipe.
+ * Initializes source and sink with the same io_context.
+ * @note Windows creates a named pipe here, where the name is automatically generated.
+diff --git a/boost/process/detail/posix/async_pipe.hpp b/boost/process/detail/posix/async_pipe.hpp
+index 725a078..a82c057 100644
+--- a/boost/process/detail/posix/async_pipe.hpp
++++ b/boost/process/detail/posix/async_pipe.hpp
+@@ -23,6 +23,7 @@ class async_pipe
+ public:
+ typedef int native_handle_type;
+ typedef ::boost::asio::posix::stream_descriptor handle_type;
++ typedef typename handle_type::executor_type executor_type;
+
+ inline async_pipe(boost::asio::io_context & ios) : async_pipe(ios, ios) {}
+
+diff --git a/boost/process/detail/windows/async_pipe.hpp b/boost/process/detail/windows/async_pipe.hpp
+index 06d5f2d..0b447f9 100644
+--- a/boost/process/detail/windows/async_pipe.hpp
++++ b/boost/process/detail/windows/async_pipe.hpp
+@@ -48,6 +48,7 @@ class async_pipe
+ public:
+ typedef ::boost::winapi::HANDLE_ native_handle_type;
+ typedef ::boost::asio::windows::stream_handle handle_type;
++ typedef typename handle_type::executor_type executor_type;
+
+ async_pipe(boost::asio::io_context & ios) : async_pipe(ios, ios, make_pipe_name(), true) {}
+ async_pipe(boost::asio::io_context & ios_source, boost::asio::io_context & ios_sink)
+--
+2.11.0
+
diff --git a/external/meta-updater/recipes-support/libp11/libp11_git.bb b/external/meta-updater/recipes-support/libp11/libp11_git.bb
deleted file mode 100644
index bedcdc82..00000000
--- a/external/meta-updater/recipes-support/libp11/libp11_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Library for using PKCS"
-DESCRIPTION = "\
-Libp11 is a library implementing a small layer on top of PKCS \
-make using PKCS"
-HOMEPAGE = "http://www.opensc-project.org/libp11"
-SECTION = "Development/Libraries"
-LICENSE = "LGPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
-DEPENDS = "libtool openssl"
-RDEPENDS_${PN} += " opensc"
-
-SRC_URI = "git://github.com/OpenSC/libp11.git"
-SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2"
-
-PV = "0.4.9+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-# Currently, Makefile dependencies are incorrectly defined which causes build errors
-# if the number of jobs is high
-# See https://github.com/OpenSC/libp11/issues/94
-PARALLEL_MAKE = ""
-EXTRA_OECONF = "--disable-static"
-
-do_install_append () {
- rm -rf ${D}${libdir}/*.la
- rm -rf ${D}${docdir}/${BPN}
-}
-
-FILES_${PN} = "${libdir}/engines*/pkcs11.so \
- ${libdir}/engines*/libpkcs11${SOLIBS} \
- ${libdir}/libp11${SOLIBS}"
-
-FILES_${PN}-dev = " \
- ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
- ${libdir}/libp11${SOLIBSDEV} \
- ${libdir}/pkgconfig/libp11.pc \
- /usr/include"
diff --git a/external/meta-updater/recipes-support/softhsm-testtoken/softhsm-testtoken.bb b/external/meta-updater/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
index 58b521c3..68514b2b 100644
--- a/external/meta-updater/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
+++ b/external/meta-updater/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
inherit systemd
-RDEPENDS_${PN} = "softhsm libp11 openssl-bin"
+RDEPENDS_${PN} = "softhsm libp11 opensc openssl-bin"
DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"