summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb')
-rw-r--r--external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb b/external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb
index b1d70f1f..b268cd38 100644
--- a/external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/external/meta-updater/recipes-test/demo-network-config/secondary-network-config.bb
@@ -2,8 +2,6 @@ DESCRIPTION = "Sample network configuration for an Uptane Secondary"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
-inherit allarch
-
# TODO: It configures the 'user' interface in NAT mode and provides an access to public Inet via it
# which is not desired for Secondary. It cannot be just removed since we get SSH access to Secondary
# VM via this interface. So, the task is to configure the interface in such way that it does provide access
@@ -12,18 +10,18 @@ SRC_URI = "\
file://27-dhcp-client-external.network \
"
-FILES_${PN} = "/usr/lib/systemd/network"
+FILES_${PN} = "${libdir}/systemd/network"
PR = "1"
do_install() {
- install -d ${D}/usr/lib/systemd/network
- install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
+ install -d ${D}${libdir}/systemd/network
+ install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/
}
-SECONDARY_IP ?= "10.0.3.2"
+SECONDARY_IP ?= "192.168.254.2"
IP_ADDR = "${SECONDARY_IP}"
-CONF_TYPE = "static"
+CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
require network-config.inc