summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb')
-rw-r--r--external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb b/external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb
new file mode 100644
index 00000000..6e813025
--- /dev/null
+++ b/external/meta-virtualization/recipes-devtools/python/python3-docker_3.4.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "A Python library for the Docker Engine API."
+HOMEPAGE = "https://github.com/docker/docker-py"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "02491d168c048cdb99cc20d0b352ea0f"
+SRC_URI[sha256sum] = "e9cc39e24905e67ba9e2df14c94488f5cf030fb72ae1c60de505ce5ea90503f7"
+
+DEPENDS += "${PYTHON_PN}-pip-native"
+
+RDEPENDS_${PN} += " \
+ python3-docker-pycreds \
+ python3-requests \
+ python3-websocket-client \
+"