summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-extended/images/container-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-virtualization/recipes-extended/images/container-base.bb')
-rw-r--r--external/meta-virtualization/recipes-extended/images/container-base.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-extended/images/container-base.bb b/external/meta-virtualization/recipes-extended/images/container-base.bb
new file mode 100644
index 00000000..434239a8
--- /dev/null
+++ b/external/meta-virtualization/recipes-extended/images/container-base.bb
@@ -0,0 +1,31 @@
+#
+# Based on examples from Scott Murray (Building Container Images with
+# OpenEmbedded and the Yocto Project) ELCe 2018
+#
+SUMMARY = "Basic container image"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+IMAGE_FSTYPES = "container oci"
+inherit image
+inherit image-oci
+
+IMAGE_FEATURES = ""
+IMAGE_LINGUAS = ""
+NO_RECOMMENDATIONS = "1"
+
+IMAGE_INSTALL = " \
+ base-files \
+ base-passwd \
+ netbase \
+"
+
+# Allow build with or without a specific kernel
+IMAGE_CONTAINER_NO_DUMMY = "1"
+
+# Workaround /var/volatile for now
+ROOTFS_POSTPROCESS_COMMAND += "rootfs_fixup_var_volatile ; "
+rootfs_fixup_var_volatile () {
+ install -m 1777 -d ${IMAGE_ROOTFS}/${localstatedir}/volatile/tmp
+ install -m 755 -d ${IMAGE_ROOTFS}/${localstatedir}/volatile/log
+}