summaryrefslogtreecommitdiffstats
path: root/external/poky/meta-selftest
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta-selftest')
-rw-r--r--external/poky/meta-selftest/COPYING.MIT17
-rw-r--r--external/poky/meta-selftest/conf/layer.conf2
-rw-r--r--external/poky/meta-selftest/lib/oeqa/runtime/cases/virgl.py18
-rw-r--r--external/poky/meta-selftest/recipes-devtools/python/python-async-test.inc16
-rw-r--r--external/poky/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb2
-rw-r--r--external/poky/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb2
-rw-r--r--external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.8.bbappend (renamed from external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend)0
-rw-r--r--external/poky/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb1
-rw-r--r--external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1-1.5.3/backported.patch37
-rw-r--r--external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb4
-rw-r--r--external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded4
-rw-r--r--external/poky/meta-selftest/recipes-test/fortran/files/hello.f955
-rw-r--r--external/poky/meta-selftest/recipes-test/fortran/fortran-helloworld.bb24
-rw-r--r--external/poky/meta-selftest/recipes-test/license/incompatible-license-alias.bb3
-rw-r--r--external/poky/meta-selftest/recipes-test/license/incompatible-license.bb3
-rw-r--r--external/poky/meta-selftest/recipes-test/license/incompatible-licenses.bb3
-rw-r--r--external/poky/meta-selftest/recipes-test/license/incompatible-nonspdx-license.bb3
-rw-r--r--external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb28
-rw-r--r--external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-test-parse.bb11
-rw-r--r--external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc5
-rw-r--r--external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile0
-rw-r--r--external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile0
-rw-r--r--external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb13
-rw-r--r--external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb14
-rw-r--r--external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb14
-rw-r--r--external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb6
-rw-r--r--external/poky/meta-selftest/wic/test_biosplusefi_plugin.wks6
27 files changed, 218 insertions, 23 deletions
diff --git a/external/poky/meta-selftest/COPYING.MIT b/external/poky/meta-selftest/COPYING.MIT
deleted file mode 100644
index 89de3547..00000000
--- a/external/poky/meta-selftest/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/external/poky/meta-selftest/conf/layer.conf b/external/poky/meta-selftest/conf/layer.conf
index 0626b2a3..a4bd461c 100644
--- a/external/poky/meta-selftest/conf/layer.conf
+++ b/external/poky/meta-selftest/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "selftest"
BBFILE_PATTERN_selftest = "^${LAYERDIR}/"
BBFILE_PRIORITY_selftest = "5"
-LAYERSERIES_COMPAT_selftest = "thud"
+LAYERSERIES_COMPAT_selftest = "dunfell"
diff --git a/external/poky/meta-selftest/lib/oeqa/runtime/cases/virgl.py b/external/poky/meta-selftest/lib/oeqa/runtime/cases/virgl.py
new file mode 100644
index 00000000..c0abfd1b
--- /dev/null
+++ b/external/poky/meta-selftest/lib/oeqa/runtime/cases/virgl.py
@@ -0,0 +1,18 @@
+from oeqa.runtime.case import OERuntimeTestCase
+from oeqa.core.decorator.depends import OETestDepends
+import subprocess
+import oe.lsb
+
+class VirglTest(OERuntimeTestCase):
+
+ @OETestDepends(['ssh.SSHTest.test_ssh'])
+ def test_kernel_driver(self):
+ status, output = self.target.run('dmesg|grep virgl')
+ self.assertEqual(status, 0, "Checking for virgl driver in dmesg returned non-zero: %d\n%s" % (status, output))
+ self.assertIn("virgl 3d acceleration enabled", output, "virgl acceleration seems to be disabled:\n%s" %(output))
+
+ @OETestDepends(['virgl.VirglTest.test_kernel_driver'])
+ def test_kmscube(self):
+ status, output = self.target.run('kmscube', timeout=30)
+ self.assertEqual(status, 0, "kmscube exited with non-zero status %d and output:\n%s" %(status, output))
+ self.assertIn('renderer: "virgl"', output, "kmscube does not seem to use virgl:\n%s" %(output))
diff --git a/external/poky/meta-selftest/recipes-devtools/python/python-async-test.inc b/external/poky/meta-selftest/recipes-devtools/python/python-async-test.inc
new file mode 100644
index 00000000..c9602e8e
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-devtools/python/python-async-test.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Python framework to process interdependent tasks in a pool of workers"
+HOMEPAGE = "http://github.com/gitpython-developers/async"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
+
+inherit pypi
+
+PYPI_PACKAGE = "async"
+
+SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
+SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-threading"
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/external/poky/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb b/external/poky/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb
new file mode 100644
index 00000000..22e241af
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-async-test.inc
diff --git a/external/poky/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb b/external/poky/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb
index 922518bc..9f905a51 100644
--- a/external/poky/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb
+++ b/external/poky/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb
@@ -8,8 +8,6 @@ SECTION = "console/utils"
LICENSE = "LGPLv2 | LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
-PR = "r1"
-
SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7"
SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1"
diff --git a/external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend b/external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.8.bbappend
index 20572098..20572098 100644
--- a/external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend
+++ b/external/poky/meta-selftest/recipes-test/aspell/aspell_0.60.8.bbappend
diff --git a/external/poky/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb b/external/poky/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb
index b377cb76..6bfc5570 100644
--- a/external/poky/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb
+++ b/external/poky/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb
@@ -9,7 +9,6 @@ SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/syslinux-${PV}.tar.x
SRC_URI[md5sum] = "92a253df9211e9c20172796ecf388f13"
SRC_URI[sha256sum] = "26d3986d2bea109d5dc0e4f8c4822a459276cf021125e8c9f23c3cca5d8c850e"
-UPSTREAM_VERSION_UNKNOWN = "1"
S = "${WORKDIR}/syslinux-${PV}"
diff --git a/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1-1.5.3/backported.patch b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1-1.5.3/backported.patch
new file mode 100644
index 00000000..c4f3f126
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1-1.5.3/backported.patch
@@ -0,0 +1,37 @@
+commit ced2ec32b657a7f52604b2e16e5d5881041c517a
+Author: OpenEmbedded <oe.patch@oe>
+Date: Mon Nov 18 18:43:15 2019 +0100
+
+ Backport of the NEWS file from version 1.6.0
+
+diff --git a/doc/NEWS b/doc/NEWS
+index 69793fc..fd49b1c 100644
+--- a/doc/NEWS
++++ b/doc/NEWS
+@@ -1,3 +1,26 @@
++1.6.0 - 15 March 2015
++ - fix lstat64 support when unavailable - separate patches supplied by
++ Ganael Laplanche and Peter Korsgaard
++ - (#1506) new option "-D" / "--delay-start" to only show bar after N
++ seconds (Damon Harper)
++ - new option "--fineta" / "-I" to show ETA as time of day rather than time
++ remaining - patch supplied by Erkki Seppälä (r147)
++ - (#1509) change ETA (--eta / -e) so that days are given if the hours
++ remaining are 24 or more (Jacek Wielemborek)
++ - (#1499) repeat read and write attempts on partial buffer fill/empty to
++ work around post-signal transfer rate drop reported by Ralf Ramsauer
++ - (#1507) do not try to calculate total size in line mode, due to bug
++ reported by Jacek Wielemborek and Michiel Van Herwegen
++ - cleanup: removed defunct RATS comments and unnecessary copyright notices
++ - clean up displayed lines when using --watchfd PID, when PID exits
++ - output errors on a new line to avoid overwriting transfer bar
++
++1.5.7 - 26 August 2014
++ - show KiB instead of incorrect kiB (Debian bug #706175)
++ - (#1284) do not gzip man page, for non-Linux OSes (Bob Friesenhahn)
++ - work around "awk" bug in tests/016-numeric-timer in decimal "," locales
++ - fix "make rpm" and "make srpm", extend "make release" to sign releases
++
+ 1.5.3 - 4 May 2014
+ - remove SPLICE_F_NONBLOCK to fix problem with slow splice() (Jan Seda)
+
diff --git a/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb
index 333ecac7..fee5bee7 100644
--- a/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb
+++ b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb
@@ -3,7 +3,9 @@ LICENSE = "Artistic-2.0"
LIC_FILES_CHKSUM = "file://doc/COPYING;md5=9c50db2589ee3ef10a9b7b2e50ce1d02"
SRC_URI = "http://www.ivarch.com/programs/sources/pv-${PV}.tar.gz \
- file://0001-Add-a-note-line-to-the-quick-reference.patch"
+ file://0001-Add-a-note-line-to-the-quick-reference.patch \
+ file://backported.patch \
+ "
UPSTREAM_CHECK_URI = "http://www.ivarch.com/programs/pv.shtml"
RECIPE_NO_UPDATE_REASON = "This recipe is used to test devtool upgrade feature"
diff --git a/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded
index 9d94f671..66e45c7e 100644
--- a/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded
+++ b/external/poky/meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded
@@ -3,7 +3,9 @@ LICENSE = "Artistic-2.0"
LIC_FILES_CHKSUM = "file://doc/COPYING;md5=9c50db2589ee3ef10a9b7b2e50ce1d02"
SRC_URI = "http://www.ivarch.com/programs/sources/pv-${PV}.tar.gz \
- file://0001-Add-a-note-line-to-the-quick-reference.patch"
+ file://0001-Add-a-note-line-to-the-quick-reference.patch \
+ file://backported.patch \
+ "
UPSTREAM_CHECK_URI = "http://www.ivarch.com/programs/pv.shtml"
RECIPE_NO_UPDATE_REASON = "This recipe is used to test devtool upgrade feature"
diff --git a/external/poky/meta-selftest/recipes-test/fortran/files/hello.f95 b/external/poky/meta-selftest/recipes-test/fortran/files/hello.f95
new file mode 100644
index 00000000..a0745fc6
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/fortran/files/hello.f95
@@ -0,0 +1,5 @@
+program helloworld
+
+ print * , "Hello World!"
+
+end program helloworld
diff --git a/external/poky/meta-selftest/recipes-test/fortran/fortran-helloworld.bb b/external/poky/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
new file mode 100644
index 00000000..3a464044
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Fortran Hello World"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "libgfortran"
+
+SRC_URI = "file://hello.f95"
+
+# These set flags that Fortran doesn't support
+SECURITY_CFLAGS = ""
+SECURITY_LDFLAGS = ""
+
+do_compile() {
+ ${FC} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
+}
+
+do_install() {
+ install -D ${B}/fortran-hello ${D}${bindir}/fortran-hello
+}
+
+python () {
+ if not d.getVar("FORTRAN"):
+ raise bb.parse.SkipRecipe("Fortran isn't enabled")
+}
diff --git a/external/poky/meta-selftest/recipes-test/license/incompatible-license-alias.bb b/external/poky/meta-selftest/recipes-test/license/incompatible-license-alias.bb
new file mode 100644
index 00000000..e0b4e13c
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/license/incompatible-license-alias.bb
@@ -0,0 +1,3 @@
+SUMMARY = "Recipe with an alias of an SPDX license"
+DESCRIPTION = "Is licensed with an alias of an SPDX license to be used for testing"
+LICENSE = "GPLv3"
diff --git a/external/poky/meta-selftest/recipes-test/license/incompatible-license.bb b/external/poky/meta-selftest/recipes-test/license/incompatible-license.bb
new file mode 100644
index 00000000..1728ad76
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/license/incompatible-license.bb
@@ -0,0 +1,3 @@
+SUMMARY = "Recipe with an SPDX license"
+DESCRIPTION = "Is licensed with an SPDX license to be used for testing"
+LICENSE = "GPL-3.0"
diff --git a/external/poky/meta-selftest/recipes-test/license/incompatible-licenses.bb b/external/poky/meta-selftest/recipes-test/license/incompatible-licenses.bb
new file mode 100644
index 00000000..9c1545ef
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/license/incompatible-licenses.bb
@@ -0,0 +1,3 @@
+SUMMARY = "Recipe with multiple SPDX licenses"
+DESCRIPTION = "Is licensed with multiple SPDX licenses to be used for testing"
+LICENSE = "GPL-2.0 & GPL-3.0 & LGPL-3.0"
diff --git a/external/poky/meta-selftest/recipes-test/license/incompatible-nonspdx-license.bb b/external/poky/meta-selftest/recipes-test/license/incompatible-nonspdx-license.bb
new file mode 100644
index 00000000..35af0966
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/license/incompatible-nonspdx-license.bb
@@ -0,0 +1,3 @@
+SUMMARY = "Recipe with a non-SPDX license"
+DESCRIPTION = "Is licensed with a non-SPDX license to be used for testing"
+LICENSE = "FooLicense"
diff --git a/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb b/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb
new file mode 100644
index 00000000..a76a6bea
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb
@@ -0,0 +1,28 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+MCMACHINE_virtclass-mcextend-musl = "qemux86-64"
+MCMACHINE_virtclass-mcextend-tiny = "qemux86"
+MCIMGTYPE_virtclass-mcextend-musl = "ext4"
+MCIMGTYPE_virtclass-mcextend-tiny = "cpio.gz"
+
+MC_DEPLOY_DIR_IMAGE = "${TOPDIR}/tmp-mc-${MCNAME}/deploy/images/${MCMACHINE}"
+
+do_install[mcdepends] += "mc::${MCNAME}:core-image-minimal:do_image_complete mc::${MCNAME}:virtual/kernel:do_deploy"
+
+do_install () {
+ install -d ${D}/var/lib/machines/${MCNAME}
+ install ${MC_DEPLOY_DIR_IMAGE}/core-image-minimal-${MCMACHINE}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/core-image-minimal.${MCIMGTYPE}
+ install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME}
+}
+
+python () {
+ mcname = d.getVar('MCNAME')
+ if not mcname:
+ raise bb.parse.SkipRecipe("Not a multiconfig target")
+ multiconfigs = d.getVar('BBMULTICONFIG') or ""
+ if mcname not in multiconfigs:
+ raise bb.parse.SkipRecipe("multiconfig target %s not enabled" % mcname)
+}
+
+BBCLASSEXTEND = "mcextend:tiny mcextend:musl"
diff --git a/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-test-parse.bb b/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-test-parse.bb
new file mode 100644
index 00000000..62366974
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/multiconfig/multiconfig-test-parse.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Test Multiconfig Parsing"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_showvar() {
+ bbplain "MCTESTVAR=${MCTESTVAR}"
+}
+addtask do_showvar
+
diff --git a/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc
new file mode 100644
index 00000000..8490b902
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc
@@ -0,0 +1,5 @@
+SRC_URI = "http://xorg.freedesktop.org/releases/individual/lib/libxshmfence-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "66662e76899112c0f99e22f2fc775a7e"
+SRC_URI[sha256sum] = "d21b2d1fd78c1efbe1f2c16dae1cb23f8fd231dcf891465b8debe636a9054b0c"
+
diff --git a/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile
diff --git a/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile
diff --git a/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb
new file mode 100644
index 00000000..0cd0494d
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Test recipe for recipeutils.patch_recipe()"
+
+require recipeutils-test.inc
+
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/somefile;md5=d41d8cd98f00b204e9800998ecf8427e"
+DEPENDS += "zlib"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += "file://somefile"
+
+SRC_URI_append = " file://anotherfile"
diff --git a/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
new file mode 100644
index 00000000..36a682c5
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
@@ -0,0 +1,14 @@
+LICENSE = "CLOSED"
+
+PROVIDES = "virtual/sysroot-test"
+INHIBIT_DEFAULT_DEPS = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+TESTSTRING ?= "1"
+
+do_install() {
+ install -d ${D}${includedir}
+ echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
+}
+
+EXCLUDE_FROM_WORLD = "1"
diff --git a/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
new file mode 100644
index 00000000..67172f3c
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
@@ -0,0 +1,14 @@
+LICENSE = "CLOSED"
+
+PROVIDES = "virtual/sysroot-test"
+INHIBIT_DEFAULT_DEPS = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+TESTSTRING ?= "2"
+
+do_install() {
+ install -d ${D}${includedir}
+ echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
+}
+
+EXCLUDE_FROM_WORLD = "1"
diff --git a/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
new file mode 100644
index 00000000..560487c1
--- /dev/null
+++ b/external/poky/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
@@ -0,0 +1,6 @@
+SUMMARY = "Virtual provider sysroot test"
+LICENSE = "CLOSED"
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS = "virtual/sysroot-test"
+
+EXCLUDE_FROM_WORLD = "1"
diff --git a/external/poky/meta-selftest/wic/test_biosplusefi_plugin.wks b/external/poky/meta-selftest/wic/test_biosplusefi_plugin.wks
new file mode 100644
index 00000000..5a56c845
--- /dev/null
+++ b/external/poky/meta-selftest/wic/test_biosplusefi_plugin.wks
@@ -0,0 +1,6 @@
+# short-description: This file is used in oe-selftest wic module to test biosplusefi plugin
+
+part /boot --source bootimg-biosplusefi --sourceparams="loader=grub-efi" --active --align 1024 --use-uuid
+part / --source rootfs --fstype=ext4 --align 1024 --use-uuid
+
+bootloader --timeout=0 --append="console=ttyS0,115200n8"