summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb')
-rw-r--r--external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb b/external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
new file mode 100644
index 00000000..08766b31
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "C implementation of createrepo."
+HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ file://0001-Correctly-install-the-shared-library.patch \
+ file://0001-Fix-setup-of-logging-log-domains-RhBug-1645897.patch \
+ "
+
+PV = "0.11.1+git${SRCPV}"
+SRCREV = "434a40babdde57ab405e9a1085a30e9575ea0c92"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
+DEPENDS_append_class-native = " file-replacement-native"
+
+inherit cmake pkgconfig bash-completion distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
+}
+
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
+ rm -rf ${D}/etc
+}