summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/go/go-cross_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/go/go-cross_1.9.bb')
-rw-r--r--external/poky/meta/recipes-devtools/go/go-cross_1.9.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/go/go-cross_1.9.bb b/external/poky/meta/recipes-devtools/go/go-cross_1.9.bb
new file mode 100644
index 00000000..4739c7d5
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/go/go-cross_1.9.bb
@@ -0,0 +1,10 @@
+require go-cross.inc
+require go-${PV}.inc
+
+export CC_FOR_TARGET = "${TARGET_PREFIX}gcc ${TARGET_CC_ARCH} --sysroot=${STAGING_DIR_TARGET}"
+export CXX_FOR_TARGET = "${TARGET_PREFIX}g++ ${TARGET_CC_ARCH} --sysroot=${STAGING_DIR_TARGET}"
+
+do_compile_prepend() {
+ export GOBIN="${B}/bin"
+ export TMPDIR="$GOTMPDIR"
+}