summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb')
-rw-r--r--external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
new file mode 100644
index 00000000..b353c21d
--- /dev/null
+++ b/external/poky/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Tools for managing Yocto Project style branched kernels"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=a6c2fa8aef1bda400e2828845ba0d06c"
+
+DEPENDS = "git-native"
+
+SRCREV = "d6529f86fc5bcb3514953ff9fa2f51a3fbf03a0f"
+PR = "r12"
+PV = "0.2+git${SRCPV}"
+
+inherit native
+
+SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git"
+S = "${WORKDIR}"
+UPSTREAM_CHECK_COMMITS = "1"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ cd ${S}/git
+ make DESTDIR=${D}${bindir} install
+}