summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb')
-rw-r--r--external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb b/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
new file mode 100644
index 00000000..94f96e62
--- /dev/null
+++ b/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}