summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/navigation')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb18
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch31
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh23
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer.service22
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_%.bbappend25
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/mapviewer_git.bb28
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-jp_1.0.bb14
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-uk_1.0.bb14
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/navigation-maps.inc14
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/navigation/0001-switch-to-pipewire-output.patch34
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch31
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/navigation/0003-update-permissions.patch22
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh61
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_uk.sh61
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf15
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/navigation_git.bb52
-rw-r--r--[-rwxr-xr-x]meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini5
-rwxr-xr-xmeta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf15
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi_git.bb14
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/poiapp_git.bb5
-rw-r--r--meta-agl-demo/recipes-demo-hmi/navigation/tbtnavi_git.bb36
21 files changed, 46 insertions, 494 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb
deleted file mode 100644
index 87087e1a..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "AGL Navigation API Library"
-DESCRIPTION = "AGL Navigation API ver 0.1.0 library for C++"
-HOMEPAGE = "https://github.com/AGLExport/agl-service-navigation"
-LICENSE = "Apache-2.0"
-SECTION = "libs"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "af-binder json-c libdbus-c++ af-main-native"
-
-inherit cmake
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-navigation;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-S = "${WORKDIR}/git"
-
-# FIXME: Remove once CMake+ninja issues are resolved
-OECMAKE_GENERATOR = "Unix Makefiles"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch b/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
deleted file mode 100644
index 9506ce11..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-gpsnavi: Fix compilation with OpenSSL 1.1
-
-Handle the ERR_load_crypto_strings and ERR_free_strings functions no
-longer being present in OpenSSL 1.1.
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
-index eadab8f..2dfe1f3 100755
---- a/src/sms/sms-core/SMCAL/SMCAL.c
-+++ b/src/sms/sms-core/SMCAL/SMCAL.c
-@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
- // 初期化
- ERR_load_BIO_strings();
- SSL_load_error_strings();
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_load_crypto_strings();
-+#endif
- OpenSSL_add_all_algorithms();
-
- // SSLの初期化(戻り値は常に1)
-@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
- if (NULL != cal->ssl.ctx) {
- SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);
- }
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_free_strings();
-+#endif
-
- cal->ssl.ssl = NULL;
- cal->ssl.ctx = NULL;
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh b/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh
deleted file mode 100755
index 0d7bf205..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-LMC=/usr/bin/LayerManagerControl
-IFS=$'\n'
-
-SURFACEID=16777216
-
-while :
-do
- /bin/sleep 1
- surfaces=()
- for line in $($LMC get surfaces 2> /dev/null); do
- if [ "X-" = "X$(echo $line | awk '{print $1}')" ]; then
- surfaceid=$(echo $line | awk '{print $3}')
- if [ "$surfaceid" = "$SURFACEID" ]; then
- $LMC set surface $SURFACEID source region 0 0 384 368
- $LMC set surface $SURFACEID destination region 0 0 384 368
- $LMC set surface $SURFACEID visibility 1
- $LMC set layer 11001 render order $SURFACEID
- exit
- fi
- fi
- done
-done
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer.service b/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
deleted file mode 100644
index 971327cc..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
+++ /dev/null
@@ -1,22 +0,0 @@
-[Unit]
-Requires=afm-api-windowmanager@0.service
-After=afm-api-windowmanager@0.service
-
-# mapviewer is a child application which can work with navigation.
-# This app requires mapdata. It has to be stored at /var/mapdata/navi_data_UK .
-# currently the position to be shown is 384x368 surface on screen 1 for cluster demo.
-
-[Service]
-Environment="XDG_RUNTIME_DIR=/run/platform/display"
-ExecStartPre=/bin/sleep 5
-ExecStart=/usr/bin/mapview
-ExecStartPost=/usr/bin/LayerManagerControl create layer 11001 1920 1080
-ExecStartPost=/usr/bin/LayerManagerControl set layer 11001 visibility 1
-ExecStartPost=/usr/bin/LayerManagerControl set screen 1 render order 11001
-ExecStartPost=/usr/AGL/mapviewer/mapviewer-settings.sh
-ExecStop=/usr/bin/killall -s KILL mapview
-Type=simple
-Restart=always
-
-[Install]
-WantedBy=afm-user-session@.target
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_%.bbappend
deleted file mode 100644
index a5597083..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ /dev/null
@@ -1,25 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://mapviewer-settings.sh \
- file://mapviewer.service \
-"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-
-do_install_append() {
- install -d ${D}${prefix}/AGL/${PN}
- install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
-
- # Install systemd unit file
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
- fi
-}
-
-SYSTEMD_SERVICE_${PN} = "mapviewer.service"
-
-FILES_${PN} += "${prefix}/AGL/${PN}/"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_git.bb
deleted file mode 100755
index 1922e7f1..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/mapviewer_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "AGL meter demo application."
-DESCRIPTION = "This application provides the function of Meter cluster to AGL. "
-HOMEPAGE = "https://github.com/AGLExport/mapviwer"
-SECTION = "apps"
-
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
- file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-
-DEPENDS = " \
- glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
- wayland \
- "
-
-RDEPENDS_${PN} = " navigation "
-
-SRCREV="2dfef5e9141ccb11f83d141c6a7dcbe0ecd49e84"
-SRC_URI="git://github.com/AGLExport/mapviwer.git \
- file://0002-openssl-1.1-fixes.patch \
-"
-
-# To avoid C++ library link failure
-SECURITY_CFLAGS = ""
-
-inherit autotools pkgconfig
-
-S = "${WORKDIR}/git"
-
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-jp_1.0.bb b/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-jp_1.0.bb
deleted file mode 100755
index 27979b3d..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-jp_1.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "AGL Reference Navigation application Japan maps"
-DESCRIPTION = "Preload the Japanese maps for the AGL Navigation application."
-HOMEPAGE = "http://agl.wismobi.com/"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-SRC_URI = "http://agl.wismobi.com/data/japan_TR9/navi_data.tar.gz"
-SRC_URI[md5sum] = "4fd44b0633d44d41c07227d086cd299c"
-SRC_URI[sha256sum] = "ce39a36741baccd6b40277acb8c81ebc181997c75483dffb46ccd22f7877295a"
-
-require navigation-maps.inc
-
-RCONFLICTS_${PN} = "navigation-maps-uk"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-uk_1.0.bb b/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-uk_1.0.bb
deleted file mode 100755
index 1718c36b..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps-uk_1.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "AGL Reference Navigation application UK maps"
-DESCRIPTION = "Preload the UK maps for the AGL Navigation application."
-HOMEPAGE = "http://agl.wismobi.com/"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-SRC_URI = "http://agl.wismobi.com/data/UnitedKingdom_TR9/navi_data_UK.tar.gz"
-SRC_URI[md5sum] = "f711c6d2c88553a1de4db9f7e12f6e8e"
-SRC_URI[sha256sum] = "515bdc81ac0615d541e0d18c186ad5cd24de2d47b60e13079a918f6dec802fd7"
-
-require navigation-maps.inc
-
-RCONFLICTS_${PN} = "navigation-maps-jp"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps.inc b/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps.inc
deleted file mode 100755
index 49b7ab49..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation-maps.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-DEPENDS = "tar-native"
-
-SRC_URI_append = ";downloadfilename=${BP}.tar.gz;unpack=0"
-
-do_compile[noexec] = "1"
-
-do_install () {
- install -d ${D}${localstatedir}/mapdata
- tar -C ${D}${localstatedir}/mapdata --no-same-owner -xf ${WORKDIR}/${BP}.tar.gz
-}
-
-FILES_${PN} += "${localstatedir}/mapdata/*"
-
-RDEPENDS_${PN} += "navigation"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0001-switch-to-pipewire-output.patch b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0001-switch-to-pipewire-output.patch
deleted file mode 100644
index 53c1165d..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0001-switch-to-pipewire-output.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-gpsnavi: Switch to pipewire output
-
-Update the talk scripts to use pipewire output via gst-launch-1.0
-instead of PulseAudio's paplay. gstreamer is used to allow using the
-pipewire output sink and set its media role property.
-
-Upstream-Status: Inappropriate [no upstream]
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/flite_agl.in b/flite_agl.in
-index 28b512c..be41d66 100644
---- a/flite_agl.in
-+++ b/flite_agl.in
-@@ -1,6 +1,6 @@
- #!/bin/sh
- TMP=/tmp/navi.wav
- echo "$1" | flite_hts_engine -m @datadir@/Voice/us/cmu_us_arctic_slt.htsvoice -o $TMP
--paplay --property='media.role=Navi' $TMP
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! pwaudiosink stream-properties="p,media.role=Navigation"
- rm -f $TMP
-
-diff --git a/jtalk_agl.in b/jtalk_agl.in
-index 76900f4..0ca6975 100644
---- a/jtalk_agl.in
-+++ b/jtalk_agl.in
-@@ -1,6 +1,6 @@
- #!/bin/sh
- TMP=/tmp/navi.wav
- echo "$1" | open_jtalk -ow $TMP -m @exec_prefix@/share/Voice/mei/mei_normal.htsvoice -x @exec_prefix@/share/dic/
--paplay --property='media.role=Navi' $TMP
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! pwaudiosink stream-properties="p,media.role=Navigation"
- rm -f $TMP
-
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch
deleted file mode 100644
index 9506ce11..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-gpsnavi: Fix compilation with OpenSSL 1.1
-
-Handle the ERR_load_crypto_strings and ERR_free_strings functions no
-longer being present in OpenSSL 1.1.
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
-index eadab8f..2dfe1f3 100755
---- a/src/sms/sms-core/SMCAL/SMCAL.c
-+++ b/src/sms/sms-core/SMCAL/SMCAL.c
-@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
- // 初期化
- ERR_load_BIO_strings();
- SSL_load_error_strings();
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_load_crypto_strings();
-+#endif
- OpenSSL_add_all_algorithms();
-
- // SSLの初期化(戻り値は常に1)
-@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
- if (NULL != cal->ssl.ctx) {
- SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);
- }
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_free_strings();
-+#endif
-
- cal->ssl.ssl = NULL;
- cal->ssl.ctx = NULL;
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0003-update-permissions.patch b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0003-update-permissions.patch
deleted file mode 100644
index 1f1ee491..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/0003-update-permissions.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-gpsnavi: Update permissions
-
-Add the new display and audio permissions required with the change to
-running as non-root.
-
-Upstream-Status: Inappropriate [no upstream]
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/agl/config.xml b/agl/config.xml
-index 9d4c0ca..44de94a 100755
---- a/agl/config.xml
-+++ b/agl/config.xml
-@@ -8,6 +8,8 @@
- <feature name="urn:AGL:widget:required-permission">
- <param name="urn:AGL:permission::public:no-htdocs" value="required" />
- <param name="http://tizen.org/privilege/internal/dbus" value="required" />
-+ <param name="urn:AGL:permission::public:display" value="required" />
-+ <param name="urn:AGL:permission::public:audio" value="required" />
- </feature>
- <feature name="urn:AGL:widget:required-api">
- <param name="homescreen" value="ws" />
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh
deleted file mode 100755
index 15120f89..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# AGL Navigation mapdata download scripts
-#
-
-#--------------------------------------------------------------
-help()
-{
-bn=`basename $0`
-cat << EOF
-usage
-host: sudo $bn 'target_rootfs_path/'
-target : $bn /
-EOF
-
-}
-#-check para-------------------------------------------------------
-shift `expr $OPTIND - 1`
-
-if [ $# != 1 ]; then
- help
- exit
-fi
-
-rootfs=$1
-
-#----------------------------------------------------------------
-
-# check the if root? ------------------------------
-userid=`id -u`
-if [ $userid -ne "0" ]; then
- echo "you're not root? run with sudo"
- exit
-fi
-
-if [ ! -e $1 ]; then
- echo "rootfs:$1 not found"
- exit
-fi
-
-if [ ! -f $HOME/navi_data.tar.gz ]; then
- echo "no map data"
- echo "start downloading..."
- wget --directory-prefix=$HOME http://agl.wismobi.com/data/japan_TR9/navi_data.tar.gz
-else
- echo "use downloaded map data"
-fi
-
-mapdatadir=$rootfs/var/mapdata
-
-if [ ! -d $mapdatadir ]; then
- echo "map data directory does not exist"
- echo "create a directory" $mapdatadir
- mkdir -p $mapdatadir
-else
- echo "map data directory exists"
-fi
-
-tar xvzf $HOME/navi_data.tar.gz -C $mapdatadir
-sync
-echo "done.."
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_uk.sh b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_uk.sh
deleted file mode 100755
index d1f9a796..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/download_mapdata_uk.sh
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# AGL Navigation mapdata download scripts
-#
-
-#--------------------------------------------------------------
-help()
-{
-bn=`basename $0`
-cat << EOF
-usage
-host: sudo $bn 'target_rootfs_path/'
-target : $bn /
-EOF
-
-}
-#-check para-------------------------------------------------------
-shift `expr $OPTIND - 1`
-
-if [ $# != 1 ]; then
- help
- exit
-fi
-
-rootfs=$1
-
-#----------------------------------------------------------------
-
-# check the if root? ------------------------------
-userid=`id -u`
-if [ $userid -ne "0" ]; then
- echo "you're not root? run with sudo"
- exit
-fi
-
-if [ ! -e $1 ]; then
- echo "rootfs:$1 not found"
- exit
-fi
-
-if [ ! -f $HOME/navi_data_UK.tar.gz ]; then
- echo "no map data"
- echo "start downloading..."
- wget --directory-prefix=$HOME http://agl.wismobi.com/data/UnitedKingdom_TR9/navi_data_UK.tar.gz
-else
- echo "use downloaded map data"
-fi
-
-mapdatadir=$rootfs/var/mapdata
-
-if [ ! -d $mapdatadir ]; then
- echo "map data directory does not exist"
- echo "create a directory" $mapdatadir
- mkdir -p $mapdatadir
-else
- echo "map data directory exists"
-fi
-
-tar xvzf $HOME/navi_data_UK.tar.gz -C $mapdatadir
-sync
-echo "done.."
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf b/meta-agl-demo/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf
deleted file mode 100644
index 7f4d85f0..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-<!DOCTYPE busconfig PUBLIC
-"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
-"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy context="default">
- <!-- Allow everyone to talk to main service. We'll later add an agent to
- only share the location if user allows it. -->
- <allow send_interface="org.agl.naviapi"/>
- </policy>
-
- <policy user="root">
- <!-- Allow root to own the name on the bus -->
- <allow own="org.agl.naviapi"/>
- </policy>
-</busconfig>
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/navigation_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/navigation_git.bb
deleted file mode 100644
index fefc0584..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/navigation_git.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-SUMMARY = "AGL Reference Navigation application."
-DESCRIPTION = "This application provides the function of Navigation to AGL. "
-HOMEPAGE = "http://agl.wismobi.com/"
-SECTION = "apps"
-
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
- file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-
-DEPENDS = " \
- glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
- wayland libdbus-c++ af-main af-binder libwindowmanager libhomescreen gstreamer1.0 \
- "
-
-RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
- wayland libdbus-c++ af-main gstreamer1.0"
-
-RDEPENDS_${PN} += " agl-service-navigation "
-
-SRCREV="89dc0052aced411ef09f8e0034fb5cf2c96ee637"
-SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
- file://0001-switch-to-pipewire-output.patch \
- file://0002-openssl-1.1-fixes.patch \
- file://0003-update-permissions.patch \
- file://download_mapdata_jp.sh \
- file://download_mapdata_uk.sh \
- file://org.agl.naviapi.conf \
-"
-
-RPROVIDES_${PN} = "virtual/navigation"
-
-# To avoid C++ library link failure
-SECURITY_CFLAGS = ""
-
-inherit autotools pkgconfig
-inherit aglwgt
-
-S = "${WORKDIR}/git"
-
-do_install_append() {
-# mapdata install scripts
- install -d ${D}/usr/AGL/apps
- install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
- install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
-
- install -d ${D}/etc/dbus-1/session.d/
- install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
-
- install -d ${D}/var/mapdata
-}
-
-FILES_${PN} += " /usr/AGL/apps/*.sh /var/mapdata "
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini b/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini
index 3a4ecc89..356c6ae6 100755..100644
--- a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini
+++ b/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini
@@ -3,6 +3,7 @@
"speed":60,
"interval":100,
"latitude":36.1363,
- "longitute":-115.151,
- "mapStyleUrls":"mapbox://styles/mapbox/dark-v9"
+ "longitude":-115.151,
+ "mapStyleUrls":"mapbox://styles/v1/mapbox/streets-v11",
+ "enableOSM":true
}
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf b/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
deleted file mode 100755
index 7f4d85f0..00000000
--- a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-<!DOCTYPE busconfig PUBLIC
-"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
-"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy context="default">
- <!-- Allow everyone to talk to main service. We'll later add an agent to
- only share the location if user allows it. -->
- <allow send_interface="org.agl.naviapi"/>
- </policy>
-
- <policy user="root">
- <!-- Allow root to own the name on the bus -->
- <allow own="org.agl.naviapi"/>
- </policy>
-</busconfig>
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi_git.bb
index 86ba5327..c52655ef 100644
--- a/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi_git.bb
+++ b/meta-agl-demo/recipes-demo-hmi/navigation/ondemandnavi_git.bb
@@ -6,32 +6,26 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS += "qtbase \
- qtquickcontrols2 \
+DEPENDS += "qtquickcontrols2 \
qlibhomescreen \
qlibwindowmanager \
qtlocation \
qtaglextras \
+ libqtappfw \
"
PV = "1.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
- file://org.agl.naviapi.conf \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
inherit qmake5 aglwgt pkgconfig
-do_install_append() {
- install -d ${D}/etc/dbus-1/session.d/
- install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
-}
-
RDEPENDS_${PN} += "qtlocation \
flite \
+ libqtappfw \
openjtalk \
gstreamer1.0 \
ondemandnavi-config \
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/poiapp_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/poiapp_git.bb
index 87263e10..b8db9ac9 100644
--- a/meta-agl-demo/recipes-demo-hmi/navigation/poiapp_git.bb
+++ b/meta-agl-demo/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -6,8 +6,9 @@ SECTION = "apps"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-DEPENDS += "qtbase json-c libnaviapi-agl \
+DEPENDS += "qtbase json-c \
qlibwindowmanager libhomescreen \
+ libqtappfw \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
@@ -17,4 +18,4 @@ S = "${WORKDIR}/git"
inherit cmake_qt5 pkgconfig aglwgt
-RDEPENDS_${PN} = "qtbase"
+RDEPENDS_${PN} = "qtbase libqtappfw"
diff --git a/meta-agl-demo/recipes-demo-hmi/navigation/tbtnavi_git.bb b/meta-agl-demo/recipes-demo-hmi/navigation/tbtnavi_git.bb
new file mode 100644
index 00000000..a61f2c92
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/navigation/tbtnavi_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "AGL Reference Navigation Cluster Streaming application"
+DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
+ file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
+ file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
+ file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
+"
+
+DEPENDS += "qtbase \
+ qtquickcontrols2 \
+ qlibhomescreen \
+ qlibwindowmanager \
+ qtlocation \
+ libqtappfw \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
+#SRCREV = "4a8b7a6301e4b093c99329d0a16fbee6c535f312"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 aglwgt pkgconfig
+
+RDEPENDS_${PN} += "qtlocation \
+ ondemandnavi-config \
+ agl-service-navigation \
+ libqtappfw \
+"