summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-demo/recipes-qt')
-rw-r--r--meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch25
-rw-r--r--meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode_git.bb3
-rw-r--r--meta-agl-demo/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch30
-rw-r--r--meta-agl-demo/recipes-qt/qt5/qtlocation_git.bbappend5
4 files changed, 27 insertions, 36 deletions
diff --git a/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch b/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch
new file mode 100644
index 00000000..489a49ed
--- /dev/null
+++ b/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch
@@ -0,0 +1,25 @@
+From 5fc5a92e3568674a08a6e7594d050e963d0d854b Mon Sep 17 00:00:00 2001
+From: Raquel Medina <raquel.medina@konsulko.com>
+Date: Mon, 18 May 2020 19:18:00 +0200
+Subject: [PATCH] fix dangling pointer
+
+Bug-AGL: SPEC-3664
+Signed-off-by: Raquel Medina <raquel.medina@konsulko.com>
+---
+ lib/qtqrcode.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/lib/qtqrcode.cpp b/lib/qtqrcode.cpp
+index a7000f0..825c354 100644
+--- a/lib/qtqrcode.cpp
++++ b/lib/qtqrcode.cpp
+@@ -116,8 +116,7 @@ void QtQrCode::setBaseQrCodeData(QRcode *qrCode)
+ {
+ d->width = qrCode->width;
+ d->data.clear();
+- // TODO: Beware it here
+- d->data = (const char *) qrCode->data;
++ d->data = QByteArray(reinterpret_cast<const char *>(qrCode->data), d->width*d->width);
+ QRcode_free(qrCode);
+ }
+
diff --git a/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode_git.bb b/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode_git.bb
index 8b3ff79a..0a7ae730 100644
--- a/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode_git.bb
+++ b/meta-agl-demo/recipes-qt/qt-qrcode/qt-qrcode_git.bb
@@ -9,7 +9,8 @@ DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtsvg qrencode"
SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https \
file://0001-rework-library-build.patch \
-"
+ file://0002-fix-dangling-pointer.patch \
+ "
SRCREV = "2d57d9c6e2341689d10f9360a16a08831a4a820b"
PV = "git${SRCPV}"
diff --git a/meta-agl-demo/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch b/meta-agl-demo/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
deleted file mode 100644
index 164c9f0e..00000000
--- a/meta-agl-demo/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 85df79b094d1097108a28424d6f9b3b76b3aee62 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Thu, 8 Nov 2018 15:26:57 +0900
-Subject: [PATCH] Fix unstable rotation gesture
-
-Order of touch events are not sorted on some platform. When touch point
-1 and
-2 are swapped, map is rotated 180 degrees in a moment
-
-Change-Id: I9c308b805a6ca54519f26a9ff19217de7f947c17
-Reviewed-by: Paolo Angelelli <paolo.angelelli@qt.io>
----
- src/location/declarativemaps/qquickgeomapgesturearea.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/location/declarativemaps/qquickgeomapgesturearea.cpp b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-index c6f4b42..576aeee 100644
---- a/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-+++ b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-@@ -1087,6 +1087,7 @@ void QQuickGeoMapGestureArea::update()
- m_allPoints << m_touchPoints;
- if (m_allPoints.isEmpty() && !m_mousePoint.isNull())
- m_allPoints << *m_mousePoint.data();
-+ std::sort(m_allPoints.begin(), m_allPoints.end(), [](const QTouchEvent::TouchPoint &tp1, const QTouchEvent::TouchPoint &tp2) { return tp1.id() < tp2.id(); });
-
- touchPointStateMachine();
-
---
-2.7.4
-
diff --git a/meta-agl-demo/recipes-qt/qt5/qtlocation_git.bbappend b/meta-agl-demo/recipes-qt/qt5/qtlocation_git.bbappend
deleted file mode 100644
index e0f3a6b2..00000000
--- a/meta-agl-demo/recipes-qt/qt5/qtlocation_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI += " \
- file://0001-Fix-unstable-rotation-gesture.patch \
-"