summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-basesystem/recipes-hal
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-agl-basesystem/recipes-hal')
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb19
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb18
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb19
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb19
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb23
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libnv-hal/libnv-hal_1.0.0.bb20
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libpositioning-hal/libpositioning-hal_1.0.0.bb24
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb18
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb20
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb18
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libupdate-hal/libupdate-hal_1.0.0.bb21
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb19
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb19
-rw-r--r--meta-agl/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb19
14 files changed, 276 insertions, 0 deletions
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb
new file mode 100644
index 00000000..0aaf69b3
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libboot_hal for AGL software"
+DESCRIPTION = "install libboot_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/boot_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "boot_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb
new file mode 100644
index 00000000..2ff52d24
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libcan_hal for AGL software"
+DESCRIPTION = "install libcan_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += "/usr/agl/include/peripheral_service/*"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/can_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "can_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb
new file mode 100644
index 00000000..71abcba8
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libclock_hal for AGL software"
+DESCRIPTION = "install libclock_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/clock_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "clock_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb
new file mode 100644
index 00000000..b34729df
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libdeck_hal for AGL software"
+DESCRIPTION = "install libdeck_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/deck_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "deck_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb
new file mode 100644
index 00000000..adc06b37
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "libinput_hal for AGL software"
+DESCRIPTION = "install libinput_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/input_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+ ns-frameworkunified\
+ drm \
+ udev \
+"
+
+HAL_NAME = "input_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libnv-hal/libnv-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libnv-hal/libnv-hal_1.0.0.bb
new file mode 100644
index 00000000..a752696c
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libnv-hal/libnv-hal_1.0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "libnv_hal for AGL software"
+DESCRIPTION = "install libnv_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN}-dev += "/usr/agl/include/native_service/* "
+
+do_package_qa[noexec] = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/nv_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "nv_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libpositioning-hal/libpositioning-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libpositioning-hal/libpositioning-hal_1.0.0.bb
new file mode 100644
index 00000000..bb1e34fd
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libpositioning-hal/libpositioning-hal_1.0.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "libpositioning_hal for AGL software"
+DESCRIPTION = "install libpositioning_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN}-dev += "/usr/agl/include/vehicle_service/*"
+
+do_package_qa[noexec] = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/positioning_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+ ns-frameworkunified \
+ ns-backupmanager \
+ vs-positioningbaselibrary \
+"
+
+HAL_NAME = "positioning_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb
new file mode 100644
index 00000000..bec6af91
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libpower_hal for AGL software"
+DESCRIPTION = "install libpower_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN}-dev += "/usr/agl/include/peripheral_service/*"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/power_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "power_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb
new file mode 100644
index 00000000..0cc9a011
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "libsecurity_hal for AGL software"
+DESCRIPTION = "install libsecurity_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN}-dev += "/usr/agl/include/system_service/*"
+
+do_package_qa[noexec] = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/security_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "security_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb
new file mode 100644
index 00000000..6f7f9c31
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libsoc_temperature-hal for AGL software"
+DESCRIPTION = "install libsoc_temperature-hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += "/usr/agl/include/system_service/*"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/soctemperature_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "soc_temperature_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libupdate-hal/libupdate-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libupdate-hal/libupdate-hal_1.0.0.bb
new file mode 100644
index 00000000..10bcf5de
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libupdate-hal/libupdate-hal_1.0.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "libupdate_hal for AGL software"
+DESCRIPTION = "install libupdate_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+ /usr/* \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/update_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+"
+
+HAL_NAME = "update_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb
new file mode 100644
index 00000000..6a50748c
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libusb_hal for AGL software"
+DESCRIPTION = "install libusb_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/usb_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "usb_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb
new file mode 100644
index 00000000..b47e16fc
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libvehicle_hal for AGL software"
+DESCRIPTION = "install libvehicle_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/vehicle_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "vehicle_hal"
diff --git a/meta-agl/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb b/meta-agl/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb
new file mode 100644
index 00000000..2ae32812
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "libvideo_in_hal for AGL software"
+DESCRIPTION = "install libvideo_in_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+inherit agl-basesystem-hal
+
+FILES_${PN} += " \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/toyota.git;protocol=https;branch=sandbox/ToshikazuOhiwa/video_in_hal"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0.0+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS += " ns-frameworkunified"
+
+HAL_NAME = "video_in_hal"