summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-agl-profile-core/recipes-devtools')
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb4
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb15
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb12
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb12
5 files changed, 43 insertions, 2 deletions
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
index 941b8033..ea3189dd 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SECTION = "apps"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "bd9e1c988ec7237964c466c65792d4c77960625e"
+SRCREV = "a357a6af0cf515883dfa26fd2cb80ac055a491de"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
index 97ce254f..647a0a81 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
@@ -4,7 +4,6 @@ LICENSE = "MIT"
inherit packagegroup
RDEPENDS_${PN} = "\
- afb-test \
strace \
ldd \
less \
@@ -25,4 +24,7 @@ RDEPENDS_${PN} = "\
libxslt-bin \
agl-service-network-tools \
gcc-sanitizers \
+ pciutils \
+ pyagl \
+ gcov \
"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
new file mode 100644
index 00000000..ab7e8afa
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "\
+AsyncSSH is a Python package which provides an asynchronous client and \
+server implementation of the SSHv2 protocol on top of the Python \
+asyncio framework."
+HOMEPAGE = "https://github.com/ronf/asyncssh"
+LICENSE = "EPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+
+SRC_URI[sha256sum] = "44bda34c7123f00c3df95d24e2dc8d43c4d17b456fbb8c434ef4f4a7ebb5265e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-asyncio ${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
new file mode 100644
index 00000000..5ff2d4ec
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-dependency manages dependencies of tests."
+HOMEPAGE = "https://github.com/RKrahl/pytest-dependency"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=35b9938ae48d25e6b8306232e98463dd"
+
+SRC_URI[sha256sum] = "c2a892906192663f85030a6ab91304e508e546cddfe557d692d61ec57a1d946b"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
new file mode 100644
index 00000000..5ed9b1d9
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-reverse is a pytest plugin to reverse test order"
+HOMEPAGE = "https://github.com/adamchainz/pytest-reverse"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=caf1f407ae86ecd57ab721dff94079b7"
+
+SRC_URI[sha256sum] = "40cbc47df8a262fed778e500f4d0b17d2d08ef8b9fbf899c0bab9488be192aac"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"