summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-agl-profile-core/recipes-devtools')
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb20
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/cmake/cmake_%.bbappend9
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/cmake/files/environment.d-cmake-agl.sh1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/gdb/.appends.core0
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/gdb/gdb_%.bbappend1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb8
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc14
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb19
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb17
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend3
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb28
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/qemu/qemu_%.bbappend1
-rwxr-xr-xmeta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts48
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service17
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb46
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts/ldconfig-wait.conf2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts_%.bbappend14
17 files changed, 248 insertions, 0 deletions
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
new file mode 100644
index 00000000..941b8033
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "CMake module to ease development of apps"
+DESCRIPTION = "This is a migration of former app-templates git submodule which let you \
+ease the development of apps and widget building."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/cmake-apps-module"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+SECTION = "apps"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "bd9e1c988ec7237964c466c65792d4c77960625e"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/cmake_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/cmake_%.bbappend
new file mode 100644
index 00000000..2de1e683
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/cmake_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/files"
+
+SRC_URI_append_class-nativesdk = " \
+ file://environment.d-cmake-agl.sh \
+"
+
+do_install_append_class-nativesdk() {
+ install -m 644 ${WORKDIR}/environment.d-cmake-agl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/cmake-agl.sh
+}
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/files/environment.d-cmake-agl.sh b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/files/environment.d-cmake-agl.sh
new file mode 100644
index 00000000..64b6cf3c
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/cmake/files/environment.d-cmake-agl.sh
@@ -0,0 +1 @@
+export OE_CMAKE_TOOLCHAIN_FILE="$OECORE_NATIVE_SYSROOT/usr/share/cmake/OEToolchainConfig.cmake"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/.appends.core b/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/.appends.core
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/.appends.core
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/gdb_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/gdb_%.bbappend
new file mode 100644
index 00000000..7cba933a
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/gdb/gdb_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG_remove = "readline"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
new file mode 100644
index 00000000..1174ac4d
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
@@ -0,0 +1,8 @@
+require libafb-helpers_git.inc
+
+inherit cmake
+
+RDEPENDS_${PN}_append = " af-binder"
+
+ALLOW_EMPTY_${PN} = "1"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
new file mode 100644
index 00000000..abb5452d
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
@@ -0,0 +1,14 @@
+SUMMARY = "AFB helpers library"
+DESCRIPTION = "AFB helpers library to ease JSON object manipulation and binding interaction"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libafb-helpers;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "547374849a76225b1a6a0dd8bb84ae27a601f19d"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder jq"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
new file mode 100644
index 00000000..7dbbb5e3
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Controller library for an Application Framework"
+DESCRIPTION = "Controller library to be used to easily create a binding for AGL App Framework"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libappcontroller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "baaa5116b2299b2b01b9fa3199ba95786c2d8a77"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder libafb-helpers lua"
+RDEPENDS_${PN}_append = " af-binder lua"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
new file mode 100644
index 00000000..59e64ce6
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Low level CAN generator"
+DESCRIPTION = "Generator used to customize low level CAN service with customs signals"
+SECTION = "devel"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit cmake pkgconfig
+BBCLASSEXTEND = "nativesdk"
+DEPENDS = " cmake-apps-module"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/low-level-can-generator;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "b7d44a2d155a1199c25b783b915fd8ba3ce42a69"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
new file mode 100644
index 00000000..a6c70934
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -0,0 +1,3 @@
+RDEPENDS_${PN} += "nativesdk-low-level-can-generator \
+ nativesdk-cmake-apps-module \
+"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
new file mode 100644
index 00000000..09f65203
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Provides a set of tools for development for AGL DISTRO"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = "\
+ afb-test \
+ strace \
+ ldd \
+ less \
+ vim \
+ lsof \
+ gdb \
+ valgrind \
+ perf \
+ htop \
+ powertop \
+ systemtap \
+ screen \
+ usbutils \
+ rsync \
+ tree \
+ pstree \
+ procps \
+ jq \
+ libxslt-bin \
+ agl-service-network-tools \
+ "
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/qemu/qemu_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/qemu/qemu_%.bbappend
new file mode 100644
index 00000000..1a6a98b7
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/qemu/qemu_%.bbappend
@@ -0,0 +1 @@
+QEMU_TARGETS_class-target_aglegvirt = " aarch64 x86_64"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
new file mode 100755
index 00000000..1d1a5a05
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
@@ -0,0 +1,48 @@
+#!/bin/sh
+#
+# Copyright 2017 IoT.bzh.
+
+# Author: Ronan Le Martret <ronan.lemartret@iot.bzh>
+#
+
+# The following script will run all the scriptlets found in #SYSCONFDIR#/agl-postinsts.
+
+agl_pi_dir="#SYSCONFDIR#/agl-postinsts"
+
+POSTINST_LOGGING=1
+LOGFILE=/var/log/agl-postinstall.log
+
+[ -e $LOGFILE ] && mv ${LOGFILE} ${LOGFILE}.old.$(date +%F--%H%M.%S)
+
+append_log=">>$LOGFILE 2>&1"
+
+exec_postinst_scriptlets() {
+ for i in `ls $agl_pi_dir`; do
+ i=$agl_pi_dir/$i
+ echo "Running postinst $i..."
+ [ "$POSTINST_LOGGING" = "1" ] && eval echo "Running postinst $i..." $append_log
+ if [ -x $i ]; then
+ eval sh -c $i $append_log
+ if [ $? -eq 0 ]; then
+ rm $i
+ else
+ echo "ERROR: postinst $i failed."
+ [ "$POSTINST_LOGGING" = "1" ] && eval echo "ERROR: postinst $i failed." $append_log
+ remove_agl_pi_dir=0
+ fi
+ else
+ echo "ERROR: postinst $i do not exists or do not have execute permission."
+ [ "$POSTINST_LOGGING" = "1" ] && eval echo "ERROR: postinst $i do not exists or do not have execute permission." $append_log
+ remove_agl_pi_dir=0
+ fi
+ done
+}
+
+remove_agl_pi_dir=1
+exec_postinst_scriptlets
+systemctl daemon-reload
+
+# since all postinstalls executed successfully, remove the postinstalls directory
+if [ $remove_agl_pi_dir = 1 ]; then
+ rm -rf $agl_pi_dir
+fi
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
new file mode 100644
index 00000000..8f8667db
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Run pending agl postinsts
+DefaultDependencies=no
+After=#SYSTEMD_SERVICE_AFTER#
+Before=#SYSTEMD_SERVICE_BEFORE#
+ConditionPathExists=#SYSCONFDIR#/agl-postinsts
+
+[Service]
+Type=oneshot
+StandardOutput=journal+console
+ExecStart=#SBINDIR#/run-agl-postinsts
+ExecStartPost=#BASE_BINDIR#/systemctl disable run-agl-postinsts.service
+RemainAfterExit=No
+TimeoutSec=0
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
new file mode 100644
index 00000000..b1ecccf8
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Runs AGL postinstall scripts on first boot of the target device"
+SECTION = "devel"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://run-agl-postinsts \
+ file://run-agl-postinsts.service"
+
+S = "${WORKDIR}"
+
+inherit allarch systemd
+
+SYSTEMD_SERVICE_${PN} = "run-agl-postinsts.service"
+
+SYSTEMD_SERVICE_AFTER ?= "dbus.service cynara.service"
+
+SYSTEMD_SERVICE_BEFORE ?= "systemd-user-sessions.service"
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/run-agl-postinsts ${D}${sbindir}/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/run-agl-postinsts.service ${D}${systemd_unitdir}/system/
+
+ sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
+ -e 's:#SBINDIR#:${sbindir}:g' \
+ -e 's:#BASE_BINDIR#:${base_bindir}:g' \
+ -e 's:#LOCALSTATEDIR#:${localstatedir}:g' \
+ ${D}${sbindir}/run-agl-postinsts \
+ ${D}${systemd_unitdir}/system/run-agl-postinsts.service
+
+ sed -i -e 's:#SYSTEMD_SERVICE_AFTER#:${SYSTEMD_SERVICE_AFTER}:g' \
+ -e 's:#SYSTEMD_SERVICE_BEFORE#:${SYSTEMD_SERVICE_BEFORE}:g' \
+ ${D}${systemd_unitdir}/system/run-agl-postinsts.service
+}
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts/ldconfig-wait.conf b/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts/ldconfig-wait.conf
new file mode 100644
index 00000000..d706cc5f
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts/ldconfig-wait.conf
@@ -0,0 +1,2 @@
+[Unit]
+After=ldconfig.service
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
new file mode 100644
index 00000000..4cc2edf8
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://ldconfig-wait.conf"
+
+do_configure_append() {
+ if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
+ sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
+ fi
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
+ install -m 0644 ${WORKDIR}/ldconfig-wait.conf ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
+}