summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-agl-profile-core')
-rw-r--r--meta-agl/meta-agl-profile-core/classes/cloc.bbclass6
-rw-r--r--meta-agl/meta-agl-profile-core/conf/include/base-agl.inc3
-rw-r--r--meta-agl/meta-agl-profile-core/files/group4
-rw-r--r--meta-agl/meta-agl-profile-core/files/passwd4
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb6
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb27
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb8
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend5
-rwxr-xr-xmeta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb3
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb5
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb19
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb8
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend3
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/0001-network-add-CAN-Termination-tristate-option.patch97
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend3
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/json-c/json-c_%.bbappend1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend34
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-multimedia/lightmediascanner/files/lightmediascanner.service4
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-platform/images/agl-image-ivi-crosssdk.bb2
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb8
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-navigation.bb17
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb19
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb1
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb4
31 files changed, 207 insertions, 96 deletions
diff --git a/meta-agl/meta-agl-profile-core/classes/cloc.bbclass b/meta-agl/meta-agl-profile-core/classes/cloc.bbclass
index 53713bfc..9b73704e 100644
--- a/meta-agl/meta-agl-profile-core/classes/cloc.bbclass
+++ b/meta-agl/meta-agl-profile-core/classes/cloc.bbclass
@@ -5,6 +5,10 @@
# summary with
# cloc --sum-reports `find . -name "*clocreport" | grep -v "\-native" ` --out summary.report
+# cloc needs to be installed on the host
+# FIXME: create a cloc-native
+HOSTTOOLS += "cloc"
+
CLOC_DIRECTORY ??= "${DEPLOY_DIR}/cloc/"
CLOCSTATEDIR = "${WORKDIR}/cloc-destdir/"
@@ -24,6 +28,6 @@ python do_cloc() {
}
-addtask cloc before do_configure after do_unpack
+addtask cloc before do_configure after do_patch
EXPORT_FUNCTIONS do_cloc
diff --git a/meta-agl/meta-agl-profile-core/conf/include/base-agl.inc b/meta-agl/meta-agl-profile-core/conf/include/base-agl.inc
index a332c08a..c5cf1a57 100644
--- a/meta-agl/meta-agl-profile-core/conf/include/base-agl.inc
+++ b/meta-agl/meta-agl-profile-core/conf/include/base-agl.inc
@@ -16,4 +16,5 @@ ASSUME_PROVIDED_remove = "tar-native"
# Use static IDs to enable full-filesystem updates
USERADDEXTENSION = "useradd-staticids"
USERADD_ERROR_DYNAMIC = "error"
-
+USERADD_GID_TABLES = "files/group"
+USERADD_UID_TABLES = "files/passwd"
diff --git a/meta-agl/meta-agl-profile-core/files/group b/meta-agl/meta-agl-profile-core/files/group
index ebf19e9a..c309f6a0 100644
--- a/meta-agl/meta-agl-profile-core/files/group
+++ b/meta-agl/meta-agl-profile-core/files/group
@@ -39,7 +39,7 @@ games::60:
shutdown::70:
users::100:
nogroup::65534:
-cynara::999:
+cynagora::999:
dhcp::998:
avahi::997:
tracing::1000:
@@ -63,7 +63,7 @@ datetime::981:
network::980:
zabbix::979:
nm-openvpn::978:
-xuser::1002:
+xuser::2002:
builder::977:
rpc::976:
crontab::975:
diff --git a/meta-agl/meta-agl-profile-core/files/passwd b/meta-agl/meta-agl-profile-core/files/passwd
index bd1788f1..ac70c0f9 100644
--- a/meta-agl/meta-agl-profile-core/files/passwd
+++ b/meta-agl/meta-agl-profile-core/files/passwd
@@ -16,7 +16,7 @@ list::38:38:::
irc::39:39:::
gnats::41:41:::
nobody::65534:65534:::
-cynara::999:999:::
+cynagora::999:999:::
dhcp::998:998:::
avahi::997:997:::
sshd::996:996:::
@@ -35,7 +35,7 @@ mysql::983:983:::
polkitd::982:982:::
zabbix::979:979:::
nm-openvpn::978:978:::
-xuser::1002:1002:::
+xuser::2002:2002:::
builder::977:977:::
rpc::976:976:::
distcc::973:65534:::
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
index 91c6b75c..d06cfd26 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -7,13 +7,13 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "087a7c0e7de28bb1c16895ef9d414666d37a35ea"
+SRCREV = "${AGL_APP_REVISION}"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS = "libafb-helpers"
-RDEPENDS_${PN} = "dev-mapping"
+DEPENDS = "libafb-helpers libappcontroller"
inherit cmake aglwgt pkgconfig ptest
+RDEPENDS_${PN} = "virtual/low-can-dev-mapping"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
new file mode 100644
index 00000000..e4dccbf3
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "HVAC Service Binding Configuration"
+DESCRIPTION = "AGL HVAC Service Binding Configuration"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
+do_install_append_ulcb() {
+ sed -i -e "s#vcan0#sllin0#g" ${D}${sysconfdir}/hvac.json
+}
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
index f5dc0814..545ab6a2 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
@@ -13,10 +13,8 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
DEPENDS = "json-c"
-RDEPENDS_${PN} += "agl-service-identity-agent"
-
-do_install_append () {
- install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
-}
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "agl-service-identity-agent agl-service-can-low-level"
+RRECOMMENDS_${PN} += "agl-service-hvac-conf"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
deleted file mode 100644
index 0817d5ed..00000000
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-# for demo
-PACKAGE_ARCH_m3ulcb = "${MACHINE_ARCH}"
-do_configure_prepend_m3ulcb() {
-sed -i -e "s#vcan0#sllin0#g" ${S}/binding/hvac-demo-binding.c
-} \ No newline at end of file
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
index c7a6fce0..71a615cf 100755
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
@@ -1,6 +1,5 @@
SUMMARY = "Navigation Service Binding"
DESCRIPTION = "AGL Navigation Service API Binding"
-HOMEPAGE = "https://github.com/AGLExport/agl-service-navigation"
SECTION = "apps"
LICENSE = "Apache-2.0"
@@ -15,3 +14,5 @@ PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "json-c libdbus-c++"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
index 742a7f7f..bf714f45 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
@@ -11,9 +11,8 @@ inherit cmake pkgconfig aglwgt ptest
DEPENDS += "lua lua-native libappcontroller libafb-helpers"
RDEPENDS_${PN} += "lua"
-SRC_URI = "gitsm://git.automotivelinux.org/apps/agl-service-signal-composer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "fe311f49703e9691fa7d515ed84a70b996f7f3e8"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-signal-composer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
new file mode 100644
index 00000000..85ebc90f
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Infotainment network device control"
+DESCRIPTION = "Abstraction layer to control INICnet devices"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-unicens-controller"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-unicens-controller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt pkgconfig
+
+DEPENDS += "json-c af-binder libafb-helpers"
+RDEPENDS_${PN} += "agl-service-unicens"
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb b/meta-agl/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
index befb5443..1309ffa2 100644
--- a/meta-agl/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
@@ -1,5 +1,3 @@
-inherit allarch
-
SUMMARY = "AGL Device mapping configuration file"
DESCRIPTION = "This provide default dev-mapping.conf file \
that defines mapping between kernel device and logical name \
@@ -8,11 +6,13 @@ DESCRIPTION = "This provide default dev-mapping.conf file \
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
SRC_URI += "file://dev-mapping.conf.default"
+inherit allarch
+
do_install() {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
diff --git a/meta-agl/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index 8057fbbc..46934588 100644
--- a/meta-agl/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -6,6 +6,9 @@ SRC_URI += "file://0001-disable-when-booting-over-nfs.patch \
FILES_${PN} += "${sysconfdir}/connman/main.conf"
+PACKAGECONFIG[session-policy-local] = "--enable-session-policy-local,--disable-session-policy-local,"
+PACKAGECONFIG_append = " session-policy-local"
+
do_install_append() {
install -d ${D}${sysconfdir}/connman
install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
diff --git a/meta-agl/meta-agl-profile-core/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-agl/meta-agl-profile-core/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
new file mode 100644
index 00000000..301a1d57
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -0,0 +1 @@
+RDEPENDS_${PN}_remove_sota = "systemtap"
diff --git a/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/0001-network-add-CAN-Termination-tristate-option.patch b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/0001-network-add-CAN-Termination-tristate-option.patch
new file mode 100644
index 00000000..3bc7a8f2
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/0001-network-add-CAN-Termination-tristate-option.patch
@@ -0,0 +1,97 @@
+From 2885f0936d3069fba7bb0078897c98f50927875c Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Wed, 19 Feb 2020 12:14:53 -0800
+Subject: [PATCH] network: add CAN Termination tristate option
+
+Upstream-Status: Submitted
+Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
+---
+ src/libsystemd/sd-netlink/netlink-types.c | 1 +
+ src/network/networkd-link.c | 13 +++++++++++++
+ src/network/networkd-network-gperf.gperf | 1 +
+ src/network/networkd-network.c | 1 +
+ src/network/networkd-network.h | 1 +
+ 5 files changed, 17 insertions(+)
+
+diff --git a/src/libsystemd/sd-netlink/netlink-types.c b/src/libsystemd/sd-netlink/netlink-types.c
+index c93fe9cb4c..0ce950d5af 100644
+--- a/src/libsystemd/sd-netlink/netlink-types.c
++++ b/src/libsystemd/sd-netlink/netlink-types.c
+@@ -298,6 +298,7 @@ static const NLType rtnl_link_info_data_geneve_types[] = {
+ static const NLType rtnl_link_info_data_can_types[] = {
+ [IFLA_CAN_BITTIMING] = { .size = sizeof(struct can_bittiming) },
+ [IFLA_CAN_RESTART_MS] = { .type = NETLINK_TYPE_U32 },
++ [IFLA_CAN_TERMINATION] = { .type = NETLINK_TYPE_U16 },
+ };
+
+ /* these strings must match the .kind entries in the kernel */
+diff --git a/src/network/networkd-link.c b/src/network/networkd-link.c
+index 4afcf843bd..af1c4ef55c 100644
+--- a/src/network/networkd-link.c
++++ b/src/network/networkd-link.c
+@@ -27,6 +27,8 @@
+ #include "util.h"
+ #include "virt.h"
+
++#define CAN_TERMINATION_OHM_VALUE 120
++
+ static bool link_dhcp6_enabled(Link *link) {
+ assert(link);
+
+@@ -1938,6 +1940,17 @@ static int link_set_can(Link *link) {
+ return log_link_error_errno(link, r, "Could not append IFLA_CAN_RESTART_MS attribute: %m");
+ }
+
++ if (link->network->can_termination >= 0) {
++
++ log_link_debug(link, "%sabling can-termination", link->network->can_termination ? "En" : "Dis");
++
++ r = sd_netlink_message_append_u16(m, IFLA_CAN_TERMINATION,
++ link->network->can_termination ? CAN_TERMINATION_OHM_VALUE : 0);
++ if (r < 0)
++ return log_link_error_errno(link, r, "Could not append IFLA_CAN_TERMINATION attribute: %m");
++
++ }
++
+ r = sd_netlink_message_close_container(m);
+ if (r < 0)
+ return log_link_error_errno(link, r, "Failed to close netlink container: %m");
+diff --git a/src/network/networkd-network-gperf.gperf b/src/network/networkd-network-gperf.gperf
+index 6ad5257f79..2f6b42809f 100644
+--- a/src/network/networkd-network-gperf.gperf
++++ b/src/network/networkd-network-gperf.gperf
+@@ -182,6 +182,7 @@ IPv6Prefix.PreferredLifetimeSec, config_parse_prefix_lifetime,
+ CAN.BitRate, config_parse_si_size, 0, offsetof(Network, can_bitrate)
+ CAN.SamplePoint, config_parse_permille, 0, offsetof(Network, can_sample_point)
+ CAN.RestartSec, config_parse_sec, 0, offsetof(Network, can_restart_us)
++CAN.Termination, config_parse_tristate, 0, offsetof(Network, can_termination)
+ /* backwards compatibility: do not add new entries to this section */
+ Network.IPv4LL, config_parse_ipv4ll, 0, offsetof(Network, link_local)
+ DHCPv4.UseDNS, config_parse_bool, 0, offsetof(Network, dhcp_use_dns)
+diff --git a/src/network/networkd-network.c b/src/network/networkd-network.c
+index 429aac5e6c..ded66f5f43 100644
+--- a/src/network/networkd-network.c
++++ b/src/network/networkd-network.c
+@@ -248,6 +248,7 @@ static int network_load_one(Manager *manager, const char *filename) {
+ network->ipv6_accept_ra_use_dns = true;
+ network->ipv6_accept_ra_route_table = RT_TABLE_MAIN;
+ network->ipv6_mtu = 0;
++ network->can_termination = -1;
+
+ dropin_dirname = strjoina(network->name, ".network.d");
+
+diff --git a/src/network/networkd-network.h b/src/network/networkd-network.h
+index 2d46d393ac..1178510107 100644
+--- a/src/network/networkd-network.h
++++ b/src/network/networkd-network.h
+@@ -190,6 +190,7 @@ struct Network {
+ size_t can_bitrate;
+ unsigned can_sample_point;
+ usec_t can_restart_us;
++ int can_termination;
+
+ AddressFamilyBoolean ip_forward;
+ bool ip_masquerade;
+--
+2.25.0
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network
index 9768c4bf..ae5514bc 100644
--- a/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network
+++ b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network
@@ -3,3 +3,4 @@ Name=can*
[CAN]
BitRate=500K
+RestartSec=0.1
diff --git a/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
index 8c7da439..078c1411 100644
--- a/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
file://e2fsck.conf \
file://canbus-can.network \
+ file://0001-network-add-CAN-Termination-tristate-option.patch \
${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
"
@@ -16,7 +17,7 @@ do_install_append() {
install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
# Install canbus network script
- install -m 0644 ${WORKDIR}/canbus-can.network ${D}${base_libdir}/systemd/network/60-canbus-can.network
+ install -m 0644 ${WORKDIR}/canbus-can.network ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
# Install DHCP configuration for Ethernet adapters
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/json-c/json-c_%.bbappend b/meta-agl/meta-agl-profile-core/recipes-devtools/json-c/json-c_%.bbappend
new file mode 100644
index 00000000..43807bd1
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/json-c/json-c_%.bbappend
@@ -0,0 +1 @@
+EXTRA_OECONF += "--enable-threading"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
index abb5452d..6753225b 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libafb-helpers;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "547374849a76225b1a6a0dd8bb84ae27a601f19d"
+SRCREV = "1d1c6cef6039effd4c045a76d30414b589336d0e"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
index 7dbbb5e3..0ee9c5e8 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libappcontroller;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "baaa5116b2299b2b01b9fa3199ba95786c2d8a77"
+SRCREV = "1bef31c8bbad27f4914484c5007b2e199fb073d4"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
index 59e64ce6..080be9a6 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
@@ -10,7 +10,7 @@ BBCLASSEXTEND = "nativesdk"
DEPENDS = " cmake-apps-module"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/low-level-can-generator;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "b7d44a2d155a1199c25b783b915fd8ba3ce42a69"
+SRCREV = "d9c40fd96e31ce41166e2b846301335ed6fe5d37"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
index 09f65203..97ce254f 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
@@ -15,7 +15,6 @@ RDEPENDS_${PN} = "\
perf \
htop \
powertop \
- systemtap \
screen \
usbutils \
rsync \
@@ -25,4 +24,5 @@ RDEPENDS_${PN} = "\
jq \
libxslt-bin \
agl-service-network-tools \
+ gcc-sanitizers \
"
diff --git a/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
index b1ecccf8..38bc66df 100644
--- a/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
@@ -13,7 +13,7 @@ inherit allarch systemd
SYSTEMD_SERVICE_${PN} = "run-agl-postinsts.service"
-SYSTEMD_SERVICE_AFTER ?= "dbus.service cynara.service"
+SYSTEMD_SERVICE_AFTER ?= "dbus.service cynagora.service"
SYSTEMD_SERVICE_BEFORE ?= "systemd-user-sessions.service"
diff --git a/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index a90210d8..17ad0558 100644
--- a/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,11 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
def prep_version (d) :
- KV = d.getVar('KERNEL_VERSION', True)
- if not KV :
- return "4.12"
- else:
- return KV
+ KV = d.getVar('KERNEL_VERSION', True)
+ if not KV :
+ return "4.12"
+ else:
+ return KV
ORIG_KERN_VER = "${@prep_version(d)}"
@@ -15,17 +15,17 @@ APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
SRC_URI_append = " \
- file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
- file://0002-src-most-add-auto-conf-feature.patch \
- file://0003-core-remove-kernel-log-for-MBO-status.patch \
- file://0004-most-video-set-device_caps.patch \
- file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
- file://0006-dim2-fix-startup-sequence.patch \
- file://0007-dim2-use-device-tree.patch \
- file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
- file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
- file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
- "
+ file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
+ file://0002-src-most-add-auto-conf-feature.patch \
+ file://0003-core-remove-kernel-log-for-MBO-status.patch \
+ file://0004-most-video-set-device_caps.patch \
+ file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
+ file://0006-dim2-fix-startup-sequence.patch \
+ file://0007-dim2-use-device-tree.patch \
+ file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
+ file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
+ file://0010-backport-usb-setup-timer.patch \
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
+ "
# Make sure we can expose KERNEL_VERSION ...
do_patch[depends] += "virtual/kernel:do_populate_sysroot"
diff --git a/meta-agl/meta-agl-profile-core/recipes-multimedia/lightmediascanner/files/lightmediascanner.service b/meta-agl/meta-agl-profile-core/recipes-multimedia/lightmediascanner/files/lightmediascanner.service
index abd7be7e..63b48ebf 100644
--- a/meta-agl/meta-agl-profile-core/recipes-multimedia/lightmediascanner/files/lightmediascanner.service
+++ b/meta-agl/meta-agl-profile-core/recipes-multimedia/lightmediascanner/files/lightmediascanner.service
@@ -1,8 +1,12 @@
[Unit]
Description=Lightmediascanner (LMS)
+After=run-agl-postinsts.service systemd-remount-fs.service systemd-tmpfiles-setup.service tmp.mount
+ConditionPathIsReadWrite=/var/volatile/tmp
[Service]
Type=dbus
+Restart=on-failure
+RestartSec=0
BusName=org.lightmediascanner
SmackProcessLabel=User::App::agl-service-mediascanner
ExecStart=/usr/bin/lightmediascannerd --startup-scan --db-path=/var/volatile/tmp/lightmediascannerd.db --directory=/media
diff --git a/meta-agl/meta-agl-profile-core/recipes-platform/images/agl-image-ivi-crosssdk.bb b/meta-agl/meta-agl-profile-core/recipes-platform/images/agl-image-ivi-crosssdk.bb
deleted file mode 100644
index 65529877..00000000
--- a/meta-agl/meta-agl-profile-core/recipes-platform/images/agl-image-ivi-crosssdk.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-# just for backward compatibility
-require agl-image-minimal-crosssdk.bb
diff --git a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb
index 03f7e40c..e209c59c 100644
--- a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb
@@ -12,12 +12,8 @@ ALLOW_EMPTY_${PN} = "1"
PKGGROUP_ZEROCONF = "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'packagegroup-base-zeroconf', '', d)}"
RDEPENDS_${PN} += "\
- bluez5-obex \
dhcp-server \
- ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-tests connman-tools connman-ncurses','',d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-tests \
+ connman-tools connman-ncurses connman-plugin-session-policy-local','',d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '${PKGGROUP_ZEROCONF}', '', d)} \
- neard \
- neardal-tools \
- rtl-sdr \
"
diff --git a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-navigation.bb b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-navigation.bb
deleted file mode 100644
index 473bac75..00000000
--- a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-navigation.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "The software for application framework of AGL IVI profile"
-DESCRIPTION = "A set of packages belong to AGL application framework which required by \
-Navigation and Location-Based Services Subsystem"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-core-navigation \
- "
-
-RDEPENDS_${PN} += "\
- gpsd \
- virtual/gpsd-conf \
- geoclue \
- "
diff --git a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
index 82cfb3a1..b6f8f07c 100644
--- a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "The minimal set of packages for Connectivity Subsystem"
+DESCRIPTION = "The minimal set of packages for AGL core Connectivity Subsystem"
LICENSE = "MIT"
inherit packagegroup
@@ -10,24 +10,7 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
-agl-service-bluetooth \
-agl-service-bluetooth-map \
-agl-service-bluetooth-pbap \
-agl-service-can-low-level \
agl-service-data-persistence \
-agl-service-geoclue \
-agl-service-geofence \
-agl-service-gps \
-agl-service-identity-agent \
-agl-service-iiodevices \
-agl-service-mediascanner \
-agl-service-navigation \
agl-service-network \
-agl-service-nfc \
-agl-service-signal-composer \
-agl-service-steering-wheel \
-agl-service-unicens \
-agl-service-weather \
agl-service-platform-info \
-high-level-viwi-service \
"
diff --git a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb
index 383b1441..284c961b 100644
--- a/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb
@@ -18,7 +18,6 @@ RDEPENDS_${PN} += "\
RDEPENDS_${PN} += "\
packagegroup-agl-core-connectivity \
- packagegroup-agl-core-navigation \
packagegroup-agl-core-os-commonlibs \
packagegroup-agl-core-services \
packagegroup-agl-core-security \
diff --git a/meta-agl/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb b/meta-agl/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
index 15fbb6f1..fc1874aa 100644
--- a/meta-agl/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SECTION = "apps"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "3605fd31f04a9198402a687b1a3242835b27cff0"
+SRCREV = "4d0948a2eeb60522b773d058f63418fd640d78c5"
DEPENDS += "lua libafb-helpers libappcontroller"
-RDEPENDS_${PN} += "lua bash"
+RDEPENDS_${PN} += "lua bash jq"
RDEPENDS_${PN}-ptest += "af-binder"
PV = "${AGLVERSION}"