summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5')
-rw-r--r--meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtlocation_%.bbappend14
-rw-r--r--meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config/qtwayland12
-rw-r--r--meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config_1.0.0.bb21
-rw-r--r--meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend1
4 files changed, 47 insertions, 1 deletions
diff --git a/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtlocation_%.bbappend b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtlocation_%.bbappend
new file mode 100644
index 00000000..bcda6a1e
--- /dev/null
+++ b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtlocation_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "\
+ file://0001-mapbox-update-API-url-to-match-new-schema.patch \
+ "
+
+# Need to explicitly enable the various plugins
+PACKAGECONFIG += " \
+ geoservices_osm \
+ geoservices_here \
+ geoservices_itemsoverlay \
+ geoservices_mapbox \
+ geoservices_mapboxgl \
+"
diff --git a/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config/qtwayland b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config/qtwayland
new file mode 100644
index 00000000..a371c6c4
--- /dev/null
+++ b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config/qtwayland
@@ -0,0 +1,12 @@
+QT_WAYLAND_SHELL_INTEGRATION=@QT_WAYLAND_DEFAULT_SHELL@
+# The following might be necessary when multiple/split surfaces are created.
+# Without this, QtWayland will sometimes maintain the same/old size even if the
+# split surface is destroyed.
+# We keep it disabled by default as it causes an additional repaint of the
+# surface until the compositor sends a configure event to scale the window to
+# the actual area. Typical windows will, by default, have an initial size set
+# by qtwayland when starting-up (without an explicit size specified by the
+# application).
+# Note that QtWayland will only test the presence of the environment variable
+# so it will be enabled even if set to 0
+# QT_WAYLAND_RESIZE_AFTER_SWAP=1
diff --git a/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config_1.0.0.bb b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config_1.0.0.bb
new file mode 100644
index 00000000..ae7c956d
--- /dev/null
+++ b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland-config_1.0.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "QtWayland config file."
+DESCRIPTION = "Config file for qtwayland."
+SECTION = "apps"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://qtwayland"
+
+inherit allarch
+
+QTWAYLAND_DEFAULT_SHELL ?= "xdg-shell"
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/qtwayland ${D}${sysconfdir}/afm/unit.env.d/qtwayland
+ sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
+}
+
+RPROVIDES_${PN} += "virtual/qtwayland-config"
diff --git a/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 33874cf4..2f6072ac 100644
--- a/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -24,4 +24,3 @@ SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
"
-SRC_URI_append = " file://0099_qtwayland_no_evdev.patch "