summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb')
-rw-r--r--meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 4a565453..66b93db5 100644
--- a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -12,7 +12,7 @@ SECTION = "base"
DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager af-binder sed m4"
DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
-RDEPENDS_${PN}_class-target += "af-binder-tools"
+RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
@@ -68,11 +68,6 @@ GROUPADD_PARAM_${PN} = "--system ${afm_name}"
RDEPENDS_${PN}_append_with-lsm-smack = " smack bash"
DEPENDS_append_with-lsm-smack = " smack-native"
-# short hacks here
-SRC_URI += "\
- file://Hack-to-allow-the-debugging.patch \
-"
-
do_install_append_class-target() {
install -d ${D}${bindir}
install -d -m 0775 ${D}${systemd_units_root}/system
@@ -90,7 +85,9 @@ do_install_append_class-target() {
ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
- echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
+
+ DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
}
pkg_postinst_ontarget_${PN}() {