summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-06-09 15:52:36 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit119d40642c13259995ee7f51fc7d887b09debd85 (patch)
tree306c36f939745ed93099bf774394ac752edc9aa9 /CMakeLists.txt
parent72ca2b377687ef63ad223ab1b55cf6bc3af24062 (diff)
cmake: visibility is hidden, do not warn about comments
Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e9ee9e..ed26d05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,8 +42,8 @@ endmacro()
add_definitions(-D_GNU_SOURCE -DDEBUG_OUTPUT)
-set(CMAKE_C_FLAGS "-Wall -fvisibility=hidden -Wextra -Wno-unused-parameter -std=c99 ${CMAKE_C_FLAGS}")
-set(CMAKE_CXX_FLAGS "-Wall -fvisibility=hidden -Wextra -Wno-unused-parameter -std=c++14 ${CMAKE_CXX_FLAGS}")
+set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-comment -Wno-unused-parameter -fvisibility=hidden -std=c99 ${CMAKE_C_FLAGS}")
+set(CMAKE_CXX_FLAGS "-Wall -Wextra -Wno-comment -Wno-unused-parameter -fvisibility=hidden -std=c++14 ${CMAKE_CXX_FLAGS}")
set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
if (NOT ${SANITIZER_MODE} STREQUAL "none" AND NOT ${SANITIZER_MODE} STREQUAL "")