summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-06-08 15:40:11 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit910704d00adeea1b6516e3fd444e5273b8ebbbbb (patch)
tree334fc70bbc928ad6ac0ade80ebd8e1f6306fbc9b /CMakeLists.txt
parent90e562cd013333084f455257edaf43c0b2258e28 (diff)
moved callback thunks to impl, makes classes readable
Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc6c88a..3e9ee9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,8 +42,8 @@ endmacro()
add_definitions(-D_GNU_SOURCE -DDEBUG_OUTPUT)
-set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused-parameter -std=c99 ${CMAKE_C_FLAGS}")
-set(CMAKE_CXX_FLAGS "-Wall -Wextra -Wno-unused-parameter -std=c++14 ${CMAKE_CXX_FLAGS}")
+set(CMAKE_C_FLAGS "-Wall -fvisibility=hidden -Wextra -Wno-unused-parameter -std=c99 ${CMAKE_C_FLAGS}")
+set(CMAKE_CXX_FLAGS "-Wall -fvisibility=hidden -Wextra -Wno-unused-parameter -std=c++14 ${CMAKE_CXX_FLAGS}")
set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
if (NOT ${SANITIZER_MODE} STREQUAL "none" AND NOT ${SANITIZER_MODE} STREQUAL "")