summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-07-13 09:30:04 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit1958da2130c04fbcc0bf1da2c40b57c785657e48 (patch)
tree5e6a47f55a519b2ded6a2955c2cb0b95435957ab /src/CMakeLists.txt
parent7678bfc942bd501f8e121ff153d1852d73578257 (diff)
glue: renamed output files to better represent their actual purpose
Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a0d3db6..ebb1946 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,9 +8,9 @@ pkg_check_modules(SD REQUIRED libsystemd>=222)
set(CMAKE_SHARED_MODULE_PREFIX "")
add_custom_command(
- OUTPUT afb_api.hpp afb_binding.inl
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding.py
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding.py)
+ OUTPUT afb_binding_api.hpp afb_binding_glue.inl
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding-glue.py
+ COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding-glue.py)
add_library(winman MODULE
main.cpp
@@ -18,7 +18,7 @@ add_library(winman MODULE
wayland.hpp
util.cpp
util.hpp
- ${IVI_CON_PROTO} json_helper.cpp json_helper.hpp app.hpp app.cpp result.hpp afb_api.hpp afb_binding.inl)
+ ${IVI_CON_PROTO} json_helper.cpp json_helper.hpp app.hpp app.cpp result.hpp afb_binding_api.hpp afb_binding_glue.inl)
target_include_directories(winman
PRIVATE