summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-07-12 15:59:37 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit54c34361d08386c751897ee215554c9ea1efd108 (patch)
tree28ae052b7e819d9f5308b3545beb029c88a476d7 /src/CMakeLists.txt
parent628df48e0238391658dab54f81dfa1c62dbfb3ec (diff)
Generating binding API glue code using generate-binding.py
Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 15ecc3c..4bb082f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,13 +7,18 @@ pkg_check_modules(SD REQUIRED libsystemd>=222)
# We do not want a prefix for our module
set(CMAKE_SHARED_MODULE_PREFIX "")
+add_custom_command(
+ OUTPUT afb_api.hpp afb_binding.inl
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding.py
+ COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding.py)
+
add_library(winman MODULE
main.cpp
wayland.cpp
wayland.hpp
util.cpp
util.hpp
- ${IVI_CON_PROTO} json_helper.cpp json_helper.hpp app.hpp app.cpp)
+ ${IVI_CON_PROTO} json_helper.cpp json_helper.hpp app.hpp app.cpp result.hpp afb_api.hpp afb_binding.inl)
target_include_directories(winman
PRIVATE