summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-06-30 13:55:12 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit8c712205657ceceb8644065735b5fff06bedfbb5 (patch)
tree4065e2f71f9a0efbffadf9a2743eccd2cac7c3a5 /src/CMakeLists.txt
parent0b491e2b69aa8f24e2e5c5982fd29b2f6952ee60 (diff)
cmake: enable _GLIBCXX_DEBUG when building Debug
Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 565f9fd..fda32c1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,6 +13,12 @@ target_compile_definitions(winman
WINMAN_VERSION_STRING="${PACKAGE_VERSION}"
_GNU_SOURCE) # XXX should I define this here?!
+if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+ target_compile_definitions(winman
+ PRIVATE
+ _GLIBCXX_DEBUG)
+endif()
+
target_compile_options(winman
PRIVATE
-Wall -Wextra -Wno-unused-parameter -Wno-comment)