summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-07-12 16:40:29 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-08-08 17:24:00 +0200
commit7678bfc942bd501f8e121ff153d1852d73578257 (patch)
tree81cb2b27743abffe319661c4f513cf9c5eada17f /src/CMakeLists.txt
parent54c34361d08386c751897ee215554c9ea1efd108 (diff)
main: move most of main to app, separate ownership
* Move everything apart from the display connection itself to App. * Everything depending on the display however is owned by App. * Dispatch events for the application in App::dispatch_events() That is, display_dispatch and local stuff e.g. execute_pending(). Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4bb082f..a0d3db6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,7 +24,8 @@ target_include_directories(winman
PRIVATE
${AFB_INCLUDE_DIRS}
${SD_INCLUDE_DIRS}
- ../include)
+ ../include
+ ../src)
target_link_libraries(winman
PRIVATE