summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..d38a6f6
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,14 @@
+wlproto(IVI_APP ivi-application)
+wlproto(IVI_CON ivi-controller)
+
+add_executable(winman
+ main.c
+ util.c
+ util.h
+ ${IVI_APP_PROTO}
+ ${IVI_CON_PROTO})
+
+add_definitions(-DWINMAN_VERSION_STRING="${PACKAGE_VERSION}")
+
+target_link_libraries(winman
+ ${WLC_LIBRARIES})