aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Diego Yamane <nick@igalia.com>2018-12-20 20:55:11 -0400
committerNick Diego Yamane <nick@igalia.com>2019-01-02 08:37:51 -0400
commite9e1d37d422da00f6b4c53fce9dccfd0ca7138db (patch)
tree0b1fcc40c1230b86df76be21421ad8c138b1e1d5 /CMakeLists.txt
parentbf18cd6b272f7975e77a577e0b0d246bb2c62964 (diff)
[backport] Force set/unset keyboard focusflounder_6.0.4flounder/6.0.46.0.4
This is work around which control keyboard focus for some applications on behalf of windowmanager or LayerManagerControl. Cherry-picked from (guppy branch): https://gerrit.automotivelinux.org/gerrit/gitweb?p=staging/xdg-launcher.git;a=commit;h=415e5cbb5787aa0429558b5256bf912231297431 Change-Id: I8e73b3fd34c076d1023060dbeef7225eebb243ca Original Author: wang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com> Signed-off-by: Nick Diego Yamane <nick@igalia.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af5e6b7..0166ece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ find_package(PkgConfig REQUIRED)
pkg_check_modules(GLIB REQUIRED glib-2.0)
pkg_check_modules(GIO REQUIRED gio-2.0)
pkg_check_modules(ILMCONTROL REQUIRED ilmControl)
+pkg_check_modules(ILMINPUT REQUIRED ilmInput)
# No configuration
# configure_file (
@@ -22,6 +23,7 @@ pkg_check_modules(ILMCONTROL REQUIRED ilmControl)
include_directories(
"include"
"${ILMCONTROL_INCLUDE_DIRS}"
+ "${ILMINPUT_INCLUDE_DIRS}"
"${GLIB_INCLUDE_DIRS}"
"${GIO_INCLUDE_DIRS}"
)
@@ -34,6 +36,7 @@ SET(LIBRARIES
windowmanager
homescreen
${ILMCONTROL_LIBRARIES}
+ ${ILMINPUT_LIBRARIES}
afbwsc
json-c
pthread