summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-12-03 19:39:12 +0000
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-12-03 19:39:12 +0000
commit415e5cbb5787aa0429558b5256bf912231297431 (patch)
tree5a72268897805028f89096afc3ab5f410b5430bb /CMakeLists.txt
parent8c5d363c334474fee33a81837f9ce4e6d2d92cd8 (diff)
Force set/unset keyboard focus
This is work around which control keyboard focus for some applications on behalf of windowmanager or LayerManagerControl. Change-Id: I3c26c4c3544b987f48d849b34a4ea10c5a05a63b Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c0cad6..f88ffbb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ find_package(PkgConfig REQUIRED)
pkg_check_modules(GLIB REQUIRED glib-2.0)
pkg_check_modules(GIO REQUIRED gio-2.0)
pkg_check_modules(ILMCONTROL REQUIRED ilmControl)
+pkg_check_modules(ILMINPUT REQUIRED ilmInput)
# No configuration
# configure_file (
@@ -22,6 +23,7 @@ pkg_check_modules(ILMCONTROL REQUIRED ilmControl)
include_directories(
"include"
"${ILMCONTROL_INCLUDE_DIRS}"
+ "${ILMINPUT_INCLUDE_DIRS}"
"${GLIB_INCLUDE_DIRS}"
"${GIO_INCLUDE_DIRS}"
)
@@ -34,6 +36,7 @@ SET(LIBRARIES
windowmanager
homescreen
${ILMCONTROL_LIBRARIES}
+ ${ILMINPUT_LIBRARIES}
afbwsc
json-c
pthread