summaryrefslogtreecommitdiffstats
path: root/templates/service/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-05 10:59:12 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-05 10:59:12 +0200
commit2b6134b5cf6515ceb096a8d490382642eaf20a9a (patch)
tree9a08587804215e1f9047bd7d770d7a1da87b7c72 /templates/service/CMakeLists.txt
parenta02d416c7e199a58dd75b7ec2a9ca45643ec393b (diff)
Update CMakeLists files tree and organization
Separation between project CMake file and Target CMake files. Adding LINK_FLAGS missing for bindings and following sources files rename operations. Change-Id: I664d20f84fd6a528fb2b057981e3ef9a4243c10d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'templates/service/CMakeLists.txt')
-rw-r--r--templates/service/CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/templates/service/CMakeLists.txt b/templates/service/CMakeLists.txt
index a0faf48..bbdab76 100644
--- a/templates/service/CMakeLists.txt
+++ b/templates/service/CMakeLists.txt
@@ -21,20 +21,7 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
-# Add target to project dependency list
-PROJECT_TARGET_ADD(service-example)
-
- # Define project Targets
- add_library(${TARGET_NAME} MODULE
- binding/xxxxxx-service-binding.c
- )
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- LABELS "BINDING"
- OUTPUT_NAME ${TARGET_NAME})
+project_subdirs_add()
project_targets_populate()
-
project_package_build()