summaryrefslogtreecommitdiffstats
path: root/templates/hybrid-html5/binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'templates/hybrid-html5/binding/CMakeLists.txt')
-rw-r--r--templates/hybrid-html5/binding/CMakeLists.txt41
1 files changed, 37 insertions, 4 deletions
diff --git a/templates/hybrid-html5/binding/CMakeLists.txt b/templates/hybrid-html5/binding/CMakeLists.txt
index 6be615f..4d73e8a 100644
--- a/templates/hybrid-html5/binding/CMakeLists.txt
+++ b/templates/hybrid-html5/binding/CMakeLists.txt
@@ -17,16 +17,32 @@
# limitations under the License.
###########################################################################
-# Add target to project dependency list
+# Project target list
+# --------------------
+# Add target to project dependency list. Name specified as argument will be
+# added to the project target list and the variable ${TARGET_NAME} become
+# available with that value.
PROJECT_TARGET_ADD(xxx)
# Define project Targets
- add_library(${TARGET_NAME} MODULE
+ add_library(${TARGET_NAME} MODULE
${TARGET_NAME}-hat.c
${TARGET_NAME}-cb.c
)
- # Binder exposes a unique public entry point
+ # Targets properties
+ # ------------------
+ # Target properties will be used to build package tree that will be
+ # built using project_package_build.
+ # OUTPUT_NAME: Depends what is the name of your output file, it is
+ # mandatory to specify which is its name with target the property
+ # OUTPUT_NAME for your target. If file name is same of your target then
+ # use variable ${TARGET_NAME}.
+ # LABELS: Choose between "BINDING", "HTDOCS", "EXECUTABLE" depending of
+ # the type of your target.
+ # PREFIX: This prefix will be added on the output file name specify with
+ # OUTPUT_NAME. By default, there isn't PREFIX on target except on
+ # library target with is "lib".
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
PREFIX "afb-"
LABELS "BINDING"
@@ -34,10 +50,27 @@ PROJECT_TARGET_ADD(xxx)
OUTPUT_NAME ${TARGET_NAME}
)
- # Library dependencies (include updates automatically)
+ # Link
+ # ----
+ # Library dependencies (include updates automatically). Linked to the
+ # target.
TARGET_LINK_LIBRARIES(${TARGET_NAME}
${link_libraries})
+ # Include
+ # -------
+ # Define target includes search and dependencies. Choose between PUBLIC,
+ # PRIVATE or INTERFACE. PRIVATE and PUBLIC items will populate the
+ # INCLUDE_DIRECTORIES property of <target>. PUBLIC and INTERFACE items
+ # will populate the INTERFACE_INCLUDE_DIRECTORIES property of <target>.
+ # The following arguments specify include directories.
+ # INTERFACE_INCLUDE_DIRECTORIES will be read at the
+ # TARGET_LINK_LIBRARIES step for others targets that link against this
+ # target.
+ TARGET_INCLUDE_DIRECTORIES( ${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
# installation directory
INSTALL(TARGETS ${TARGET_NAME}
LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})