summaryrefslogtreecommitdiffstats
path: root/templates/service/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'templates/service/CMakeLists.txt')
-rw-r--r--templates/service/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/templates/service/CMakeLists.txt b/templates/service/CMakeLists.txt
index 12a069b..1ddb659 100644
--- a/templates/service/CMakeLists.txt
+++ b/templates/service/CMakeLists.txt
@@ -21,8 +21,13 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+# Will add each subdirs with a CMakeLists.txt file
project_subdirs_add()
+# Populate each target with LABELS specified.
project_targets_populate()
+# Build package widget once populated.
project_package_build()
-project_closing_msg() \ No newline at end of file
+
+#Display CLOSING_MESSAGE specified in config.cmake file.
+project_closing_msg()