aboutsummaryrefslogtreecommitdiffstats
path: root/theme/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'theme/setup.py')
-rw-r--r--theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/theme/setup.py b/theme/setup.py
new file mode 100644
index 0000000..444ca07
--- /dev/null
+++ b/theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+VERSION = '1.0.4'
+
+setup(
+ name="mkdocs-windmill",
+ version=VERSION,
+ url='https://github.com/gristlabs/mkdocs-windmill',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Documentation',
+ 'Topic :: Text Processing',
+ ],
+ install_requires=[
+ 'mkdocs',
+ ],
+ license='MIT',
+ description='MkDocs theme focused on navigation and usability',
+ author='Dmitry S',
+ author_email='dmitry@getgrist.com',
+ packages=find_packages(),
+ include_package_data=True,
+ entry_points={
+ 'mkdocs.themes': [
+ 'windmill = mkdocs_windmill',
+ ]
+ },
+ zip_safe=False
+)