aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-01-16 20:29:54 -0500
committerScott Murray <scott.murray@konsulko.com>2019-01-16 20:32:08 -0500
commit13ef75141312d50c2d4caeffe4ba0e132752cf99 (patch)
tree6fad10e18ff1897615adcc6f39490c52459decd5
parent251fb524e791d40cb7a7e1581649e63da9da3b08 (diff)
cluster-windowmanager-conf: Update configurationhalibut_7.90.0halibut/7.90.0guppy_6.99.4guppy/6.99.47.90.06.99.4
Update the recipe and files to handle the rename of areas.db to areas.json and the significant rewrite of layers.json. Change-Id: I9af4e6bf29e8983568126c92b17645be4735dabe Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.json (renamed from recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.db)0
-rw-r--r--recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/layers.json84
-rw-r--r--recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb4
3 files changed, 47 insertions, 41 deletions
diff --git a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.db b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.json
index 00322ac..00322ac 100644
--- a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.db
+++ b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/areas.json
diff --git a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/layers.json b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/layers.json
index 1fd9d18..5c6a5b3 100644
--- a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/layers.json
+++ b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf/layers.json
@@ -1,41 +1,47 @@
{
- "comment": "Surface ID to Layer ID mapping",
-
- "main_surface": {
- "surface_role": "HomeScreen",
- "comment": "This surface should never be made invisible (The HomeScreen)"
- },
-
- "mappings": [
- {
- "role": "BackGroundLayer",
- "name": "BackGroundLayer",
- "layer_id": 999,
- "comment": "Single BackGround layer map for the map, radio, music and video"
- },
- {
- "role": "homescreen",
- "name": "FarHomeScreen",
- "layer_id": 1000,
- "comment": "FarHomeScreen is the part of HomeScreen. The z order of this layer is lower than NearHomeScreen"
- },
- {
- "role": "receiver|fallback",
- "name": "Apps",
- "layer_id": 1001,
- "comment": "Range of IDs that will always be placed on layer 1001"
- },
- {
- "role": "restriction",
- "name": "Restriction",
- "layer_id": 1002,
- "comment": "This layer is for restriction notification. This is used by restriction role"
- },
- {
- "role": "^on_screen.*",
- "name": "OnScreen",
- "layer_id": 9999,
- "comment": "Range of IDs that will always be placed on the OnScreen layer, that gets a very high 'dummy' id of 9999"
- }
- ]
+ "description": "Layer mapping",
+ "mappings": [
+ {
+ "name": "BackGroundLayer",
+ "role" : "receiver",
+ "id_range_begin": 0,
+ "id_range_end": 0,
+ "comment": "Work Around: This is a special fallback layer that not stopping wayland event loop."
+ },
+ {
+ "name": "FarHomeScreen",
+ "role": "homescreen",
+ "id_range_begin": 100,
+ "id_range_end": 199,
+ "comment": "FarHomeScreen is the part of HomeScreen. The z order of this layer is lower than NearHomeScreen"
+ },
+ {
+ "name": "Apps",
+ "role": "receiver|fallback",
+ "id_range_begin": 1000,
+ "id_range_end": 2999,
+ "comment": "Application layer"
+ },
+ {
+ "name": "Popup",
+ "role": "popup*",
+ "id_range_begin": 4000,
+ "id_range_end": 4999,
+ "comment": "This layer is for popup application layer"
+ },
+ {
+ "name": "Restriction",
+ "role": "restriction",
+ "id_range_begin": 5000,
+ "id_range_end": 5999,
+ "comment": "This layer is for restriction notification on driving. This is used by restriction role"
+ },
+ {
+ "name": "OnScreen",
+ "role": "^on_screen.*",
+ "id_range_begin": 6000,
+ "id_range_end": 6999,
+ "comment": "System notification layer. For example, on_screen_low_battery_alert to notify user"
+ }
+ ]
}
diff --git a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
index 0cef85c..4be666b 100644
--- a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
+++ b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "file://layers.json \
- file://areas.db \
+ file://areas.json \
file://roles.db \
"
@@ -12,7 +12,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${sysconfdir}/xdg/windowmanager
install -m 0644 ${WORKDIR}/layers.json ${D}${sysconfdir}/xdg/windowmanager/layers.json
- install -m 0644 ${WORKDIR}/areas.db ${D}${sysconfdir}/xdg/windowmanager/areas.db
+ install -m 0644 ${WORKDIR}/areas.json ${D}${sysconfdir}/xdg/windowmanager/areas.json
install -m 0644 ${WORKDIR}/roles.db ${D}${sysconfdir}/xdg/windowmanager/roles.db
}