aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-06-24 18:51:19 +0300
committerMarius Vlad <marius.vlad@collabora.com>2020-07-10 00:47:01 +0300
commit5386a6059ae3b5dc7bd17721981d47b051966895 (patch)
tree48acd9d10e28477ff78bbdbb9d346edcadaf5053
parentc0065f1323621982cac5a3f4c8096f73ce0aac04 (diff)
cluster-receiver_git: Add cluster-receiver wayland depends
cluster-receiver application will be a Qt application so add Qt specific dependencies for it. Also, add base and bad gstreamer plug-ins, as those are needed. Bug-AGL: SPEC-3382 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ie4c73bc0c9b8746f086a94785debf300f33fa824
-rw-r--r--recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
index 6420511..2b9721c 100644
--- a/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
+++ b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
@@ -14,9 +14,12 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS = "wayland wayland-ivi-extension libwindowmanager gstreamer1.0"
+DEPENDS += "wayland wayland-native \
+ qtwayland qtwayland-native \
+ qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-inherit cmake aglwgt
+inherit cmake_qt5 pkgconfig aglwgt
RDEPENDS_${PN} += " \
gstreamer1.0-plugins-base \