aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-07-13 18:43:59 +0300
committerMarius Vlad <marius.vlad@collabora.com>2020-07-14 19:20:41 +0300
commitc44f58e8ab9f728b89f4293297897c073e25f90b (patch)
tree49f0df90d5d50d155e957e8aa50290fad97b4a7c
parentca5910f05b2b6bded4afc389170aa5bc14bc8a3d (diff)
qt-cluster-receiver: Added new recipe for the qt cluster receiver applicationjellyfish_9.99.4jellyfish_9.99.3jellyfish/9.99.4jellyfish/9.99.39.99.49.99.3
And enable it in the cluster-demo-platform. Swaps depedencies between the native C application and the Qt version. Bug-AGL: SPEC-3382 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I147113eb0d3a0fbb6759225706ee856d76304ac8
-rw-r--r--recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb7
-rw-r--r--recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb28
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb1
3 files changed, 31 insertions, 5 deletions
diff --git a/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
index 1e21565..e339388 100644
--- a/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
+++ b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bb
@@ -4,8 +4,7 @@ HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/a
SECTION = "apps"
LICENSE = "Apache-2.0 & MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
- file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
@@ -15,11 +14,9 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "wayland wayland-native \
- qtwayland qtwayland-native \
- qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-inherit cmake_qt5 pkgconfig aglwgt
+inherit cmake pkgconfig aglwgt
RDEPENDS_${PN} += " \
gstreamer1.0-plugins-base \
diff --git a/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb b/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
new file mode 100644
index 0000000..10728d5
--- /dev/null
+++ b/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Instrument Cluster Receiver AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "wayland wayland-native \
+ qtwayland qtwayland-native \
+ qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
+
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
index 13ffb72..2ca89e4 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
@@ -22,6 +22,7 @@ RDEPENDS_${PN} += "\
AGL_APPS = " \
cluster-dashboard \
cluster-receiver \
+ qt-cluster-receiver \
"
AGL_APIS = " \