aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 16:46:37 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-10 13:50:24 -0500
commit251fb524e791d40cb7a7e1581649e63da9da3b08 (patch)
tree1c39d533cb1a7318b83146a0e43e563654f0f6fb /conf
parent7ea4459ecd58198e4932db3f41fadecf0024325c (diff)
Define instrument cluster demo platform. This layer is similar to meta-agl-demo, except it defines a small platform for the instrument cluster demo, based on the agl-profile-cluster-qt5 profile. There is a "agl-cluster-demo" feature defined to enable building the platform. At the moment, only qemux86-64 and Minnowboard turbot versions have been built and tested. Other architectures should be feasible, but the agl-cluster-demo-receiver application needs some further development to support non-Intel platforms, as currently it is using the vaapisink gstreamer plug-in. Change-Id: I217608a1ecc9678d5d55a95c65f3ab6f10d5b54f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/conf-notes.txt4
-rw-r--r--conf/include/agl-cluster-demo.inc5
-rw-r--r--conf/layer.conf10
3 files changed, 19 insertions, 0 deletions
diff --git a/conf/conf-notes.txt b/conf/conf-notes.txt
new file mode 100644
index 0000000..2060128
--- /dev/null
+++ b/conf/conf-notes.txt
@@ -0,0 +1,4 @@
+Common targets are:
+ agl-cluster-demo-platform
+ agl-cluster-demo-platform-crosssdk
+ agl-cluster-demo-platform-qa
diff --git a/conf/include/agl-cluster-demo.inc b/conf/include/agl-cluster-demo.inc
new file mode 100644
index 0000000..a8847e0
--- /dev/null
+++ b/conf/include/agl-cluster-demo.inc
@@ -0,0 +1,5 @@
+IMAGE_FEATURES =+ "debug-tweaks"
+
+#DISTRO_FEATURES_append = " "
+
+#IMAGE_INSTALL_append = " "
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..3e98b51
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "agl-cluster-demo"
+BBFILE_PATTERN_agl-cluster-demo = "^${LAYERDIR}/"
+BBFILE_PRIORITY_agl-cluster-demo = "7"