aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/cluster-dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-03 18:03:05 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-03 23:07:17 +0000
commit728764b79d6027b7d91cbb80e0ea690ba3c737d2 (patch)
treeebb815cf818758751eae1169004eca062c4c16e6 /recipes-demo-hmi/cluster-dashboard
parent46a5c08387cb501cb2b70e7cffb6d7518cbf0cbe (diff)
Add support for CAN driven speeds for the demo dashboardicefish_8.99.5icefish/8.99.58.99.5
Changes include: - Update cluster-dashboard recipe to pull in libqtappfw for signal-composer support - Add signal-composer and required low-can and gps bindings to agl-cluster-demo-platform image - Add recipe to install configuration file that tells the cluster-dashboard app to use signal-composer vehicle and engine speed events instead of running the default animation loop, and a new agl-cluster-demo-preload feature template that drives adding the recipe to the image for demo purposes. Bug-AGL: SPEC-3045 Change-Id: I193f9fd764b7610eaacc4c524522552bcc1e7ccc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/cluster-dashboard')
-rw-r--r--recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
index 74974eb..5420d34 100644
--- a/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
@@ -14,7 +14,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtwebsockets qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 qtwebsockets qlibwindowmanager libqtappfw glib-2.0"
inherit pkgconfig cmake_qt5 aglwgt
@@ -24,6 +24,6 @@ RDEPENDS_${PN} += " \
qtquickcontrols-qmlplugins \
qtquickcontrols2 \
qtquickcontrols2-qmlplugins \
- qtwebsockets \
- qtwebsockets-qmlplugins \
+ libqtappfw \
+ agl-service-signal-composer \
"